Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2004, 01:39 PM   #1
Mr.Freeze
Scooby Specialist
 
Member#: 12692
Join Date: Nov 2001
Chapter/Region: MWSOC
Location: ...now i think i'm ready, to
Vehicle:
bust a move check it
out i'm rockin' steady

Default Car needs 2-3 turns for engine to start?

Well I have a 1993 Impreza L FWD as my beater. I have started to notice that it takes 2-3 turns before the engine turns over. Could it be the battery, starter, spark plug cables, or other?

Reason I say the plug cables is that I had to replace one, but the smart guy I am I found an old one from my 1993 Prelude I used to own...I used that one as a temp fix and it worked (no problems for first couple weeks) then this started.

The car has 159k on it and has been excellent thus far with only this minor problem.

Any thoughts?
* Registered users of the site do not see these ads.
Mr.Freeze is offline   Reply With Quote
Old 05-16-2004, 07:37 PM   #2
twizzstyle
Scooby Guru
 
Member#: 18941
Join Date: May 2002
Chapter/Region: NWIC
Location: Kenmore, Washington
Vehicle:
2005 Lotus Elise
Orange

Default

Try charging your battery, and see if it does it quicker.
twizzstyle is offline   Reply With Quote
Old 05-16-2004, 08:40 PM   #3
JonofScio
Scooby Newbie
 
Member#: 53595
Join Date: Jan 2004
Chapter/Region: NWIC
Location: nowehres
Vehicle:
1987 GL Hatch
EA81 1.6L + Weber

Default

I agree. Your battery may be the problem. Although, new spark plug wires and better spark plugs wouldn't hurt at all.
JonofScio is offline   Reply With Quote
Old 05-17-2004, 07:40 PM   #4
Section 8
Scooby Specialist
 
Member#: 821
Join Date: Jan 2000
Chapter/Region: MWSOC
Location: "Like a hyena you are..."
Default

Hey Nermit,

I left my dome light on in the car visiting a friend for 3 days in 15-20 degrees below zero temps. After jump starting the car and getting home, starting the car always took a couple spins more to fire. a year and a few months later I left the car undriven for 3-4 weeks and the battery just completely died with out warning. I put a new battery in it and it starts almost immediatly again.

The battery can cause this problem, and it would be great if it was, but it might not be. There are other problems that could be causing hard starting as well.

If the car isn't struggling to start, and idels fine when cold, it is most likely the battery.

cheeRS,

Greg
Section 8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hydra 2.5 does not want to start... acssa Other Engine Management 16 01-27-2009 09:53 AM
Honda to develop entry-level car in 2, 3 years AVANTI R5 Non-Subaru News & Rumors 0 12-17-2008 11:55 AM
whats a good base engine to start a big hp project? dubaru General Community 25 09-10-2004 03:11 AM
Need Tech 3 Map for Ludespeed Stage 2, plz :) subaru kym Southern California Impreza Club Forum -- SCIC 6 02-18-2004 03:30 AM
Help!!! need 2 3 inch gaskets for MRT exhaust SilverBoosted Mid Atlantic Impreza Club -- MAIC 3 07-23-2002 12:36 PM


All times are GMT -4. The time now is 04:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.