Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-19-2004, 04:05 PM   #1
globalmike
Scooby Newbie
 
Member#: 50553
Join Date: Dec 2003
Default uppipe/downpipe cel?

so i installed an uppipe and gutted the down pipe should i expect to to see and cel's?
* Registered users of the site do not see these ads.
globalmike is offline   Reply With Quote
Old 05-19-2004, 06:04 PM   #2
Flexx999
Scooby Specialist
 
Member#: 36302
Join Date: May 2003
Chapter/Region: W. Canada
Location: St. Albert, Alberta
Vehicle:
2006 Big 16G WRX
Addicted to Blue

Default

From what I have read about other peoples mods on exhaust I would say more then likely you will throw one. But there are fixes for that if you do.
Flexx999 is offline   Reply With Quote
Old 05-20-2004, 02:11 AM   #3
brianbot5000
Scooby Specialist
 
Member#: 44000
Join Date: Sep 2003
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2013 2013 WRX Hatch
1997 Toyota Tacoma

Default

Couple threads I just bookmarked on this very subject last night...doing some pre-mod research.

mechanical CEL fix for catless downpipe:
http://forums.nasioc.com/forums/show...l&pagenumber=1

and

http://forums.nasioc.com/forums/show...666&perpage=25

For uppipde cel fix (aka, EGT sensor fix):

http://forums.nasioc.com/forums/show...hreadid=548451
brianbot5000 is offline   Reply With Quote
Old 05-20-2004, 10:24 AM   #4
bigbear522
Scooby Specialist
 
Member#: 21304
Join Date: Jul 2002
Location: AB
Vehicle:
2002 Impreza WRX
Funky Silver Party Wagon

Default

You will throw your EGT CEL when you burn out your probe, it takes about 6 months.

you will throw your O2 CEL when your driving in 5th gear and your above 60% throttle.

So you have to do these mods if you want to go catless.

For your uppipe, you will need a RESISTOR fix.. 2.2ohm 1/2W resistor. The the two end of the resistor can be plugged into the harness side of the EGT probe.

resistor can be picked up at any electronic store

For your downpipe you will need a O2 sensor fix that can be picked up here. (REMEMBER TO RESET YOUR CAR AFTER THIS MOD)

ponyexpressperformance.com


hope this helps.

Byron
bigbear522 is offline   Reply With Quote
Old 05-20-2004, 01:02 PM   #5
globalmike
Scooby Newbie
 
Member#: 50553
Join Date: Dec 2003
Default

i thought that the mechanical fix was the only one that worked for an 2004.

also thanks for the help.

mike
globalmike is offline   Reply With Quote
Old 05-20-2004, 06:35 PM   #6
LowUFO
Scooby Newbie
 
Member#: 36495
Join Date: May 2003
Location: Toronto
Vehicle:
2004 WRX
Black Pearl

Default

I don't know where I am going wrong, but I have both the resistor fix and the mechanical fix. Still got the CEL. Came on right after I installed the dp and haven't been able to get rid of it permanently.
I have an 04 wrx.
LowUFO is offline   Reply With Quote
Old 05-20-2004, 08:11 PM   #7
R.C.Y.K.
Scooby Specialist
 
Member#: 10389
Join Date: Sep 2001
Location: Edmonton, Alberta, Canada
Vehicle:
2002

Default

i have egt cel be4, now it is gone with the resister mod. and i only get the dp o2 cel when i am driving long time with 5th gear. but it will be gone after a tank of gas
R.C.Y.K. is offline   Reply With Quote
Old 05-20-2004, 11:30 PM   #8
bigbear522
Scooby Specialist
 
Member#: 21304
Join Date: Jul 2002
Location: AB
Vehicle:
2002 Impreza WRX
Funky Silver Party Wagon

Default

I did't know you have a 04... sorry I have a 02, old school fix!
bigbear522 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uppipe/Downpipe Cel fixes totalburnout Factory 2.0L Turbo Powertrain 30 11-09-2006 01:14 PM
WRX 02 - 05 Up & Down Pipe Cel Fix uppipe downpipe jasonpig Private 'For Sale' Classifieds 18 06-29-2006 01:12 PM
Helix Uppipe, Downpipe and CEL - anything else..? prototypeWRX Texas Impreza Club Forum -- TXIC 4 03-09-2005 03:50 PM
CEL question related to uppipe/downpipe Moshpit552 Newbies & FAQs 3 08-21-2004 02:38 AM
Perrin Gen III Uppipe Install = CEL scoobyrex Factory 2.0L Turbo Powertrain 9 07-22-2002 10:07 AM


All times are GMT -4. The time now is 03:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.