Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-01-2004, 04:39 PM   #1
Puckman
Scooby Newbie
 
Member#: 61554
Join Date: May 2004
Default climate control lights and some more

Guys, got a really wierd problem. The lights that light up the actual symbols on the climate control (you know, the vent, the defroster symbol, etc) don't work. The light bellow them that lets you know you what you have selected does work. Also, my crusie control symbol and reardefroster symbol don't light up, but my fog light one does. Has anyone had any similar problems or ideas on how to fix it. You think it might just be a bulb thats blown?

thanks!
* Registered users of the site do not see these ads.
Puckman is offline   Reply With Quote
Old 06-01-2004, 05:02 PM   #2
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Default

It seems pretty common for the dash bulbs to go out I'm finding. Here is a link that will help some:

http://www.scoobymods.com/forums/showthread.php?t=91

and:

http://www.scoobymods.com/forums/sho...ght=Dash+Bulbs
Peaty is offline   Reply With Quote
Old 06-01-2004, 10:00 PM   #3
Puckman
Scooby Newbie
 
Member#: 61554
Join Date: May 2004
Default

thanks, hopefully this will fix it!
Puckman is offline   Reply With Quote
Old 06-01-2004, 10:03 PM   #4
sha_zapple
Scooby Specialist
 
Member#: 41012
Join Date: Aug 2003
Chapter/Region: E. Canada
Vehicle:
1998 Legacy L

Default

im 100% sure its the bulbs. cheap, but getting to the old bulbs is a pain.
sha_zapple is offline   Reply With Quote
Old 06-01-2004, 10:42 PM   #5
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

Quote:
Originally posted by sha_zapple
im 100% sure its the bulbs. cheap, but getting to the old bulbs is a pain.
its not that bad.

also a tip, it is easiest to remove the cold/hot cable down on the passenger side, just under the glove box.
subiekid is offline   Reply With Quote
Old 06-01-2004, 11:34 PM   #6
IronMonkeyL255
Scooby Specialist
 
Member#: 38120
Join Date: Jun 2003
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
1991 Rio Red
Legacy Turbo

Default

Quote:
Originally posted by subiekid
its not that bad.

also a tip, it is easiest to remove the cold/hot cable down on the passenger side, just under the glove box.
You shouldn't have to remove that.

I found (when playing with an old HVAC unit) that once you remove the electrical connector from the back of the unit, you can just slide most of the unit out (after removing the slider knobs).

There are 2 tabs (one on either side) that you can just lift off with a screw driver (don't pry too hard, as they are prone to snap off) and slide the part with the buttons right out. The only part that is left are the sliders and all the electrical stuff for them.

That also exposes the back of the bulbs so you can just pop them out (actually, they twist out.....).


I have done a bit of messing around with the HVAC unit and found all this out.
IronMonkeyL255 is offline   Reply With Quote
Old 06-01-2004, 11:36 PM   #7
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

hmm, well with my car when i took the HAVC out I would not really get to the back all that well. did you try in a 91 or a 95+?

i took a havc out of a 92 and it had way more cable that alowed the unit to pull out more then the 95.
subiekid is offline   Reply With Quote
Old 06-02-2004, 03:58 PM   #8
Puckman
Scooby Newbie
 
Member#: 61554
Join Date: May 2004
Default

thanks guys, probably should have added that it's on a 98 legacy. A question for anyone who has done this. Would you recommend using the bulbs obtained from subaru, or should i go with the ones from radio shack?

Thanks
Puckman is offline   Reply With Quote
Old 06-02-2004, 04:26 PM   #9
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Default

The OEM bulbs are a lot easier to deal with but they are on the expensive side. I used the OEM bulbs myself though.
Peaty is offline   Reply With Quote
Old 06-02-2004, 04:36 PM   #10
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

its not that expensive, it was only like 8 bucks for all 3 bulbs, and if you need the ones for the cruise/fogs/defrost it should be around 20 bucks.

otherwise you have to take appart each little plastic assembly and fit each bulb in. and do all of them at the same time, dont just do one, cause it could be any time that the next one will blow.
subiekid is offline   Reply With Quote
Old 06-02-2004, 10:04 PM   #11
sha_zapple
Scooby Specialist
 
Member#: 41012
Join Date: Aug 2003
Chapter/Region: E. Canada
Vehicle:
1998 Legacy L

Default

I have a 98 and i fixed the cruise and hazard light. I used the bulbs from CT. Putting the new bulbs in the old plastic assemply is pretty easy. Only cost me like, 2 bucks as well
sha_zapple is offline   Reply With Quote
Old 06-03-2004, 02:41 AM   #12
monovich
Scooby Specialist
 
Member#: 8124
Join Date: Jul 2001
Location: Denver, Colorado
Vehicle:
1998 Old Grey Mule
Regacy Rype R

Default

I need to do this soon, too.

ALL my HVAC and hazard lights are burnt out.

Can these be ordered online? I could maybe just order from subarparts.com
monovich is offline   Reply With Quote
Old 06-03-2004, 02:55 AM   #13
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

i think the part numbers are on the subymods site but you have to pay for that site now. i think i still have hte part numbers i will go look for them tomorrow.
subiekid is offline   Reply With Quote
Old 06-03-2004, 11:48 AM   #14
Puckman
Scooby Newbie
 
Member#: 61554
Join Date: May 2004
Default

Yeah i had to pay to get the info. Here it is:

For the fog light/cruise/reardefroster:
83426AA040 clear bulb
83426AA051 orange

For the actual climate control panel you need:
2 Short bulbs PN 72351AC061 (Bulb Mode Temp)
1 Long bulb PN 72351AC051 (Bulb Fan)
Puckman is offline   Reply With Quote
Old 06-03-2004, 11:33 PM   #15
monovich
Scooby Specialist
 
Member#: 8124
Join Date: Jul 2001
Location: Denver, Colorado
Vehicle:
1998 Old Grey Mule
Regacy Rype R

Default

is the Hazard light one of these, or is it another bulb?
monovich is offline   Reply With Quote
Old 06-04-2004, 12:02 AM   #16
IronMonkeyL255
Scooby Specialist
 
Member#: 38120
Join Date: Jun 2003
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
1991 Rio Red
Legacy Turbo

Default

it's another bulb.

It's in another assemly, I believe.
IronMonkeyL255 is offline   Reply With Quote
Old 06-04-2004, 12:49 AM   #17
monovich
Scooby Specialist
 
Member#: 8124
Join Date: Jul 2001
Location: Denver, Colorado
Vehicle:
1998 Old Grey Mule
Regacy Rype R

Default

anyone got a part number?
monovich is offline   Reply With Quote
Old 06-04-2004, 01:15 AM   #18
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

Sorry, I had to watch my neice all night. I will look around in my room and see if I have the packages still.

I know i have one in my tool box outside.

Be back in a bit.
subiekid is offline   Reply With Quote
Old 06-04-2004, 01:31 AM   #19
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

hmm, well since i had gone to college my dad had cleaned out the shed, I will have to look tomorrow. I know that there is 3 bulbs, you need one long one and 2 short ones. I will look tomorrow.
subiekid is offline   Reply With Quote
Old 06-04-2004, 09:29 AM   #20
sha_zapple
Scooby Specialist
 
Member#: 41012
Join Date: Aug 2003
Chapter/Region: E. Canada
Vehicle:
1998 Legacy L

Default

READ the scoobymods threads, it has ALL this information.

EDIT: Looks like scoobymods is pay... boourns. There must be a thread around here with the info
sha_zapple is offline   Reply With Quote
Old 06-04-2004, 09:33 AM   #21
NicoGamine
Scooby Newbie
 
Member#: 57079
Join Date: Mar 2004
Vehicle:
2000 Legacy L Wagon
Light green

Default

Quote:
Originally posted by sha_zapple
READ the scoobymods threads, it has ALL this information.
We can't, it now asks for registration: http://www.scoobymods.com/forums/showthread.php?t=3626

I've posted a mod, so I'll be able to get a free membership, but others will have to pay.

Nicolas
NicoGamine is offline   Reply With Quote
Old 06-04-2004, 03:16 PM   #22
Puckman
Scooby Newbie
 
Member#: 61554
Join Date: May 2004
Default

read up in the post a little bit, and i list the part numbers for everything but the hazard light switch
Puckman is offline   Reply With Quote
Old 06-05-2004, 02:34 AM   #23
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

OKay i found one of hte lights.


the smaller bulb which you will need 2 of is # 72351AC061
if you call the dealer and ask them they will be able to tell you what the other part number is for the longer bulb. I haveyet to replace the fog light/cruise/rear def lights but i think the blulbs are all the same.


again, you can call your dealer and get the parts numbers.

if anyone needs anymore info just ask, I can try to get all the part numbers if you all want. it will have to wait till wednesday.
subiekid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cluster and climate control lights 04wgnNJ Newbies & FAQs 4 03-03-2009 11:04 PM
NO dash lights and climate control lights blkbdrx Electrical & Lighting 4 10-24-2003 11:09 PM
Climate controls lighting BluSuby Legacy Forum 18 12-31-2002 04:44 PM
How to replace climate control lights? Snowphun Legacy Forum 4 04-12-2002 02:20 AM
climate control lights iceman Interior & Exterior Modification 4 02-09-2001 07:50 PM


All times are GMT -4. The time now is 03:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.