Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-06-2004, 12:58 AM   #1
jmj1112
Scooby Specialist
 
Member#: 57051
Join Date: Mar 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
02 WRX
WRB

Default STI Ver8 cluster in my 02 WRX

Like the title says....Little help needed if somebody has done this already!!!!

Hooked it up and now I have some problems..

First, some how it has effected the radio unit...It blew the fuse after I first installed it....replaced the fuse....blew it again.

Second, the lights in the dash do not dim...not sure if this is correct the other items dim like the boost gauge.

The next couple of things are no big deal...would like to disconect the DCCD light and the Rear dif temp lights.

I'm sure I am not the first to do this conversion and that this probably happed to them.

I did a search but did not find anything.

Thanks for any help!!!!!

Jay
* Registered users of the site do not see these ads.
jmj1112 is offline   Reply With Quote
Old 06-06-2004, 03:33 AM   #2
unloadmydodads
Scooby Newbie
 
Member#: 34615
Join Date: Mar 2003
Vehicle:
2003 Subaru WRX
Silver

Default

I just put my ver.8 cluster in this past week. The reason you are blowing the fuse in the radio is because you did't cut the b28 wire. The wire you need to cut is on the middle harness(the big one in the middle), it is the yellow wire with the green tracer. I would highly recommend doing another search just to make sure this is the right wire. Try searching "sti gauge cluster" look for the post with about 19 pages to it and start reading. The lights on the gauge cluster do dim. First you have to turn the right knob to you get to the "ILL5" lcd menu on the right. You then have to turn the left knob to the left to dim the cluster. I know in the 19 page thread they tell you which wires to cut to disable the DCCD and Rear Diff lights, but I didn't do this. Just make sure you find the thread first. Good luck and if you have anymore questions shoot me a pm.
unloadmydodads is offline   Reply With Quote
Old 06-07-2004, 01:53 AM   #3
jmj1112
Scooby Specialist
 
Member#: 57051
Join Date: Mar 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
02 WRX
WRB

Default

Perfect......that is a long thread.....needed to read more into it before I started....

Thanks

Jay

http://forums.nasioc.com/forums/show...i&pagenumber=1
jmj1112 is offline   Reply With Quote
Old 06-12-2004, 10:44 PM   #4
ljaviation
Scooby Specialist
 
Member#: 42270
Join Date: Aug 2003
Chapter/Region: South East
Location: Asheboro, NC
Vehicle:
2003 A&P IA
ww.flyingleafaviation.com

Default

That was a good thread.. and don't forget to wire up that OAT
ljaviation is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 Sti Gauge Cluster In My 02 Wrx HOOGUNZO Subaru Conversions 2 07-16-2008 05:32 AM
06 sti gauge cluster in an 02 wrx lovemyrex Electrical & Lighting 2 10-19-2007 12:32 AM
sti gauge cluster in an 02 wrx? michaelpatrick Electrical & Lighting 0 05-10-2006 01:35 PM
USDM STi ver8 cluster in a 2003 WRX? HOPPFL Electrical & Lighting 3 07-14-2004 09:28 AM
STI Vers8 cluster in a 02 WRX jmj1112 Subaru Conversions 1 06-07-2004 01:54 AM


All times are GMT -4. The time now is 06:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.