Welcome to the North American Subaru Impreza Owners Club Monday May 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-08-2004, 04:07 PM   #1
soccer_freak_m@hotma
Scooby Specialist
 
Member#: 47261
Join Date: Nov 2003
Chapter/Region: W. Canada
Location: Edmonton, Alberta
Default fuel pump fuse

I hope this isn't cross-posting or whatever... but no one answered me in the other thread

Where is the fuse to the fuel pump?
* Registered users of the site do not see these ads.
soccer_freak_m@hotma is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-09-2004, 03:12 AM   #2
damianq
Scooby Specialist
 
Member#: 5380
Join Date: Apr 2001
Location: Edmonton
Vehicle:
1999 Impreza
Primer

Default

Engine bay me thinks?
damianq is offline   Reply With Quote
Old 06-09-2004, 08:05 AM   #3
soccer_freak_m@hotma
Scooby Specialist
 
Member#: 47261
Join Date: Nov 2003
Chapter/Region: W. Canada
Location: Edmonton, Alberta
Default

nah... people did reply to my other post and it's fuse #11...

apparently I can also let the car sit for an hour or so and the pressure should have dissipated
soccer_freak_m@hotma is offline   Reply With Quote
Old 06-10-2004, 10:05 AM   #4
damianq
Scooby Specialist
 
Member#: 5380
Join Date: Apr 2001
Location: Edmonton
Vehicle:
1999 Impreza
Primer

Default

Easiest way is to open the gas tank cap, loosen the clamp around the line & pull the line off the filter w/ a rag around it. Thank way any pressurized fuel gets caught by the rag, instead of spraying all over the engine bay & yourself.
damianq is offline   Reply With Quote
Old 06-10-2004, 10:32 AM   #5
soccer_freak_m@hotma
Scooby Specialist
 
Member#: 47261
Join Date: Nov 2003
Chapter/Region: W. Canada
Location: Edmonton, Alberta
Default

I did it this way...

1. pull fuse #11 (fuel pump)
2. turn on car (let die)
3. try to turn over car couple more times
4. loosen the clamps on the lines
5. pull off the lines (wrapped my hand in a rag to catch any fuel - was a dribble and that's it)
6. pulled off the rubber protector thingy
7. took off the clip that hold the lines
8. installed new filter
9. turn over engin and let run for a little while while checking for leaks from hoses.

All that took all of 5 minutes and there was only a tiny dribble when I pulled off the filter. I'm also told that's the way the mech.s at the dealerships do it.
soccer_freak_m@hotma is offline   Reply With Quote
Old 06-11-2004, 07:05 AM   #6
damianq
Scooby Specialist
 
Member#: 5380
Join Date: Apr 2001
Location: Edmonton
Vehicle:
1999 Impreza
Primer

Default

As long as it works eh?
damianq is offline   Reply With Quote
Old 06-11-2004, 09:11 AM   #7
soccer_freak_m@hotma
Scooby Specialist
 
Member#: 47261
Join Date: Nov 2003
Chapter/Region: W. Canada
Location: Edmonton, Alberta
Default

Quote:
Originally posted by damianq
As long as it works eh?
for sure... as long as i works... well
soccer_freak_m@hotma is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pump fuse? generalwrx Newbies & FAQs 4 12-23-2004 02:55 PM
Fuel Pump Fuse? samli77 Texas Impreza Club Forum -- TXIC 1 02-12-2004 03:51 PM
fuel pump fuse? sparta65 Service & Maintenance 2 08-03-2002 08:46 PM
Location of fuel pump fuse turbonutterbastard Service & Maintenance 1 04-14-2002 10:03 AM
Where's the fuel pump fuse? subachad Normally Aspirated with bolt-on Forced Induction Powertrain 5 08-18-2001 12:16 AM


All times are GMT -4. The time now is 01:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.