Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-12-2004, 09:42 PM   #1
awd4ever
Scooby Specialist
 
Member#: 31573
Join Date: Jan 2003
Chapter/Region: NWIC
Location: land of kirk
Vehicle:
I found the
meaning of life!

Default Something blew, not sure what

Hi, last night on the way home my car started making a hissing sound. Interesting thing is, this happened when car was not being pushed hard, if at all.

Car idles normal, no RPM spikes, but at idle it's making sound like something is clanking inside the block. Thought i blew the SC, but after removing the belts clanking continued. Under boost the car sounds like it's leaking mass boost and it seems quiet a bit weaker.

Initial ideas:
Crank bearing or bent valve.

Setup:
98 block (130k), new style HG
5psi on supercharger
J&E, S-AFC, valbo...

Thoughts?
* Registered users of the site do not see these ads.
awd4ever is offline   Reply With Quote
Old 06-12-2004, 11:59 PM   #2
awd4ever
Scooby Specialist
 
Member#: 31573
Join Date: Jan 2003
Chapter/Region: NWIC
Location: land of kirk
Vehicle:
I found the
meaning of life!

Default

Checked compression, comes back fine:
right side: 195, 195
left side: 185, 182

Prolly a bearing... hate taking the block out again
awd4ever is offline   Reply With Quote
Old 06-13-2004, 12:03 AM   #3
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default block

time for an ej22t
IllNastyImpreza is offline   Reply With Quote
Old 06-13-2004, 01:45 AM   #4
awd4ever
Scooby Specialist
 
Member#: 31573
Join Date: Jan 2003
Chapter/Region: NWIC
Location: land of kirk
Vehicle:
I found the
meaning of life!

Default

you know... i was not impressed with the numbers at 16 psi. Actually, i was dissapointed. I would have expected a 2.2 @16psi to push over 300.
awd4ever is offline   Reply With Quote
Old 06-13-2004, 02:21 AM   #5
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
DIY project: life
I need more TIME!

Default block

the block is wicked heavy...its meant to handle ALOT more boost than that. 25 PSI ALL DAY LONG on stock internals...slap new rods in there and your talking 30+!.....RELIABLY
IllNastyImpreza is offline   Reply With Quote
Old 06-13-2004, 02:54 AM   #6
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

Quote:
Originally posted by awd4ever
you know... i was not impressed with the numbers at 16 psi. Actually, i was dissapointed. I would have expected a 2.2 @16psi to push over 300.
maybe with a monster lagy turbo. 16psi is not much at all. Guys on legacy central have been running 22psi for daily driving for years now.
subiekid is offline   Reply With Quote
Old 06-13-2004, 10:46 PM   #7
awd4ever
Scooby Specialist
 
Member#: 31573
Join Date: Jan 2003
Chapter/Region: NWIC
Location: land of kirk
Vehicle:
I found the
meaning of life!

Default

So, we got a little update.

I drove the car for a bit today, and the sound went away. Now we all know broken bearings dont go away, so i think a piece of gasket or a small rock got sucked in from the header side.

Long story short, i was going to replace my headers, new one didnt fit, so i plugged old ones with old gaskets... possibly it broke, and piece was wobbling in the combustion chaimber.

Is there a way to determine if any of the valves are bent?
...it would suck to remove intake mani, as i have a supercharger...

Thanks
awd4ever is offline   Reply With Quote
Old 06-14-2004, 08:58 AM   #8
Elliot
Scooby Specialist
 
Member#: 12732
Join Date: Nov 2001
Location: Dorado Puerto Rico
Vehicle:
2000 2.5RS-T
Titanium silver

Default

If the compression test came good the valves must be ok!!
Elliot is offline   Reply With Quote
Old 06-14-2004, 10:17 AM   #9
IdenityCrisis
Scooby Specialist
 
Member#: 55007
Join Date: Feb 2004
Location: Livonia City:-), Michigan
Vehicle:
2000 RSti SilvEaton
Resurected and Swapped

Default

hey, what kind os sc setup do you have? and where you at? might be able to swap ideas. i'm currently having engine probs. i'm loosing 5psi somewhere. and my engine is quite tired. - IC
IdenityCrisis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Something broke- but not sure what madmax718 Service & Maintenance 13 02-09-2009 06:23 PM
Need something... not sure what its called Pick9811 Electrical & Lighting 8 05-24-2008 08:05 PM
Exhaust rattle or something else....not sure RoadTrippin Service & Maintenance 1 04-26-2008 06:14 PM
Not sure what this part is called... but damn sure hard to find! Skin Irritant Newbies & FAQs 28 01-09-2008 05:15 PM
Did something to the impreza and not sure what nutrigrainkiller Newbies & FAQs 2 03-12-2006 07:28 PM


All times are GMT -4. The time now is 06:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.