Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-27-2004, 09:48 PM   #1
import111
Scooby Specialist
 
Member#: 24447
Join Date: Sep 2002
Chapter/Region: SWIC
Location: Tucson, Arizona
Vehicle:
2010 Evo GSR
GG

Default squeeking?

I got a F.A.T. stage 3 kit installed about 1 week ago. When I got back to Tucson and rolled down the windows, I noticed a very loud squeeking. It has been squeeking since the install. If I grab the intake where it connects to the turbo and shake the whole motor, it causes the squeeking. I can't seem to find what exactly is squeeking or how to stop it. Anyone else have/had this problem and/or know what it is?
Ryan
* Registered users of the site do not see these ads.
import111 is offline   Reply With Quote
Old 06-27-2004, 11:41 PM   #2
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default

Intercooler against the firewall?
scoobyimprza is offline   Reply With Quote
Old 06-27-2004, 11:58 PM   #3
import111
Scooby Specialist
 
Member#: 24447
Join Date: Sep 2002
Chapter/Region: SWIC
Location: Tucson, Arizona
Vehicle:
2010 Evo GSR
GG

Default

I checked the spacing between the firewall and intercooler and there is plenty of room. No squeeking coming from there. Thanks for the sugestion though. I appreciate it.
Ryan
import111 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeek...squeek...squeek...HELP! Snakebot Texas Impreza Club Forum -- TXIC 21 10-20-2006 12:03 AM
('93-'01) Help! What is that squeek! Kalins1 Impreza Forum 16 04-27-2001 01:45 AM
Fix for random body squeeking- check the sunroof! glenstiles SVX Forum Archive 0 01-31-2001 08:32 PM
Mini Squeeking noise under the Legacy Apexboy Legacy Forum 6 03-23-2000 09:30 PM
Squeeking Noise Miller3339 Legacy Forum 7 03-16-2000 10:23 PM


All times are GMT -4. The time now is 02:04 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.