Welcome to the North American Subaru Impreza Owners Club Wednesday January 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-06-2004, 04:45 PM   #1
Rowdy2.5
Scooby Specialist
 
Member#: 7005
Join Date: May 2001
Chapter/Region: TXIC
Location: Where I run out of gas...
Vehicle:
2000 2.5 RS
SM and Anthrocite

Unhappy O2 Sensor still bad after recall?

Could anyone remind me which O2 sensor was fixed with a recall.

MY00 Impreza 2.5RS

I belive it was the one on the "Bank 1" or before the cat.

Me engine turned on so I went to my friendly Vatozone and that's what they told me...





Kev, any thoughts?

I won't say the name of the dealership until after someone posts a response...

it wasn't SOD
* Registered users of the site do not see these ads.
Rowdy2.5 is offline   Reply With Quote
Old 07-06-2004, 05:49 PM   #2
2Point5RS
Scooby Specialist
 
Member#: 3639
Join Date: Jan 2001
Chapter/Region: TXIC
Location: Bedford, TX
Default

Bank 1 Sensor 1.

I just changed mine about 6-7 months ago. It's already gone bad again. PITA POS
2Point5RS is offline   Reply With Quote
Old 07-06-2004, 11:48 PM   #3
ruiner
Scooby Specialist
 
Member#: 20784
Join Date: Jul 2002
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2002 Impreza WRX
WR Blue

Default

My Bank 1 sensor is also out. This however is on an 02 WRX. Is there a similar situation with the WRX? I would love to have this replaced as a recall rather than pay $152 from subaruparts.com.

Chad
ruiner is offline   Reply With Quote
Old 07-07-2004, 03:47 AM   #4
petrol
Scooby Guru
 
Member#: 18861
Join Date: May 2002
Chapter/Region: TXIC
Location: DFW
Vehicle:
9999 Porsche 911
black

Default

Call tomorrow and ask the SA at SoD. (acronym hell?) They can look it up quick, and tell you what recalls/bulletins apply to your Subys.

IIRC, emissions components are covered under a different warranty than powertrain, etc. You may be covered by warranty even if there isnt a recall.

Rowdy, if you go to a decent Subaru dealer, a quick look with the Select Monitor will show if your O2 sensors are functioning properly. It will also give more detailed descriptions of stored CEL codes/diagnostic information.
petrol is offline   Reply With Quote
Old 07-07-2004, 02:12 PM   #5
Rowdy2.5
Scooby Specialist
 
Member#: 7005
Join Date: May 2001
Chapter/Region: TXIC
Location: Where I run out of gas...
Vehicle:
2000 2.5 RS
SM and Anthrocite

Default

What are your hours of operation?


SA = ?????
Rowdy2.5 is offline   Reply With Quote
Old 07-07-2004, 02:41 PM   #6
wcbjr
Scooby Guru
 
Member#: 4001
Join Date: Feb 2001
Location: I love spherical bearings!
Vehicle:
2006 Legacy GT
Obsidian black

Default

Service Advisor.
wcbjr is offline   Reply With Quote
Old 07-07-2004, 04:36 PM   #7
Rowdy2.5
Scooby Specialist
 
Member#: 7005
Join Date: May 2001
Chapter/Region: TXIC
Location: Where I run out of gas...
Vehicle:
2000 2.5 RS
SM and Anthrocite

Default

Quote:
Originally posted by wcbjr
Service Advisor.
Tuche!
Rowdy2.5 is offline   Reply With Quote
Old 07-07-2004, 09:25 PM   #8
petrol
Scooby Guru
 
Member#: 18861
Join Date: May 2002
Chapter/Region: TXIC
Location: DFW
Vehicle:
9999 Porsche 911
black

Default

Touche' even!

8a-6pm
petrol is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why would my rear O2 sensor go out after 1100 miles? MattDell Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 08-30-2004 11:05 PM
How to tell if O2 sensor is bad paulw Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 11-03-2002 03:07 PM
O2 sensor gone bad? scootr Normally Aspirated with bolt-on Forced Induction Powertrain 4 05-10-2002 05:08 AM
Recall O2 sensor before or after MRT exhaust? Julian Normally Aspirated Powertrain 5 02-22-2001 08:09 PM
How to tell if a O2 sensor is bad??? RugDoc2003 General Forum Archive 21 02-21-2001 05:16 PM


All times are GMT -4. The time now is 08:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.