Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-27-2000, 01:10 PM   #1
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Exclamation Turboing a MY00 auto

I know of the "bug" that one can't boost past 3psi. I also know there are people running around with more than 5psi as well.

What would I need to do/get in order to run 5psi?

Thanks.
* Registered users of the site do not see these ads.
Keiho is offline   Reply With Quote
Old 10-27-2000, 01:13 PM   #2
ColinL
Scooby Guru
 
Member#: 114
Join Date: Jul 1999
Chapter/Region: MWSOC
Location: Wichita, KS and Whoring, OT
Vehicle:
'03 Evo, Rice White
'01 Erion CBR 929

Post

Check valves or a MAP sensor voltage clamp.
ColinL is offline   Reply With Quote
Old 10-27-2000, 01:44 PM   #3
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Post

What exactly are those?
Keiho is offline   Reply With Quote
Old 10-27-2000, 01:59 PM   #4
stimpy
Homicidal Maniac
Moderator
 
Member#: 1612
Join Date: Jun 2000
Location: Austin, TX
Vehicle:
2008 STI

Post

It makes it so
a: (check valves) the MAP sensor doesnt read a positive manifold pressure

or

b: (voltage clamp) the MAP sensor signal doesnt report a positive manifold pressure to the ECU

[EDIT] oops, it put frowny faces in there when it shouldnt have

option c: would be to contact JC Sports and they seem to have a "black box" that fixes the MY00 and MY01 boost problems.

[This message has been edited by stimpy (edited October 27, 2000).]
stimpy is offline   Reply With Quote
Old 10-27-2000, 02:35 PM   #5
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Post

I have contacted JC Sports already, they haven't gotten back to me yet.

How would one go about in "doing" the check valves or voltage clamp? Is it safe to do so?
Keiho is offline   Reply With Quote
Old 10-27-2000, 08:04 PM   #6
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2015 Forester 2.0 XT
2005 2.5 RS, 2013 Tribeca

Post

I'll be at JC Sports all day tomorrow and will ask them to contact you about the "MY00/01" boost fix. It might be that they only include them with turbo kits they sell.

I have their "black box" in my MY00 RS turbo, and I am pushing 7 psi with it, no problem.

Larry www.ImprezaRS.com
ImprezaRS dot com is offline   Reply With Quote
Old 10-28-2000, 01:35 AM   #7
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Post

Thanks Larry!
Keiho is offline   Reply With Quote
Old 10-28-2000, 02:35 AM   #8
SnapperHead
Scooby Newbie
 
Member#: 2740
Join Date: Oct 2000
Location: Schaumburg IL
Post

Ask them if they're including anything extra in the $800 they tacked onto the stage II, or if its just inflation.
SnapperHead is offline   Reply With Quote
Old 10-28-2000, 11:09 PM   #9
rpone605
Scooby Specialist
 
Member#: 1669
Join Date: Jun 2000
Location: Cleveland, Ohio
Vehicle:
2004 WRX Sport Wagon
Silver

Post

instead of the check valve or the wiring thing...you could just get the tecII kit and do it that way.
rpone605 is offline   Reply With Quote
Old 10-28-2000, 11:32 PM   #10
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2015 Forester 2.0 XT
2005 2.5 RS, 2013 Tribeca

Talking

re: cost of turbo kits.

They are updating their product line with a line of three less expensive IHI kits, (with one under $3K) and then a line of three Garrett kits which are more expensive.

The site update and new pricing for IHI kits should be set within a month or so. Right now they are busy with their move and completing the group buy kits.

As for the check valve and wiring thing vs TECII - there is a big difference between a $200 "black box" to fix boost and a $2000 ECU - there is no comparison if you have the money to spend. I'd love a TECII - if someone gave me one I wouldn't turn them away...

Larry www.ImprezaRS.com
ImprezaRS dot com is offline   Reply With Quote
Old 10-29-2000, 02:12 AM   #11
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Post

Yes, I'd love to have a TEC-II as well, just that I don't have the bones to cough up. Trying to get a turbokit to begin with is already making life difficult for me!
Keiho is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my turboed whip..my00 GregBolby Member's Car Gallery 43 01-12-2007 10:34 AM
turbo magazine tokyo auto salon 2003 Otaku64 General Community 4 10-07-2002 11:43 PM
Thoughts on a T3 turbo for a my00 Auto 2.5rs ! HELP! DarkLite Factory 2.0L Turbo Powertrain 16 03-29-2001 11:27 AM
Legacy Turbo in MY00, who has done this? bluesaint Normally Aspirated Powertrain 6 11-10-2000 07:20 PM
MY00 Auto tranny Dyno results! HomerJay Technical Forum Archive 1 08-07-2000 01:59 PM


All times are GMT -4. The time now is 06:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.