Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-24-2000, 04:26 AM   #1
Pipercub
Scooby Specialist
 
Member#: 2188
Join Date: Aug 2000
Location: Remington VA`
Vehicle:
2004 Impreza STI
82 BRAT with 12 in. lift

Post SAFC Throttle missing 10%

Just installed my SAFC and I have a very odd reading. The sensor check tracks the voltage from my TPS as going from 0.0 to 4.2~3 and in all respects seems to opperate just fine. The problem is that fully floored all I get is 90% on the throttle reading on the SAFC. I could find no adjustment for the endpoints which made me wonder something. The manual indicates that on different vehicles the TPS may produce 0-3, 0-4, 0-5. How does it know when it reaches 100% if there is no provision to tell it what 100% is? It would stand to reason that you must be able to set the maximum so it knows what 100% is. What are your experiences and what is you rmaximum indicated throttle percentage?
* Registered users of the site do not see these ads.
Pipercub is offline   Reply With Quote
Old 10-24-2000, 09:46 AM   #2
Scooter
Scooby Newbie
 
Member#: 75
Join Date: Jul 1999
Location: Farmington,CT,USA
Post

Do you know anybody with a Laptop and OBD II scan tool software? With such software you could do a check to see if you get the same 90% reading from the ECU. If so, then your throttle may not be opening fully or your TPS could be off.

Here's a link to a Fluke DMM application note that talks a little bit about checking such things. Even without a DMM you could still check if the throttle is actually opening all the way. If it is opening all the way, but the ECU says it's only 90% open, then your TPS might need adjusting.
http://www.fluke.com/application_not...AGID=1&SID=103

[This message has been edited by Scooter (edited October 24, 2000).]
Scooter is offline   Reply With Quote
Old 10-24-2000, 11:27 AM   #3
MPREZYA
SCIC
Moderator
 
Member#: 85
Join Date: Jul 1999
Chapter/Region: SCIC
Location: www.themonkeystrunk.com
Post

Make sure your floor mat or something isn't underneath or in the way of the gas pedal near the fire wall that will keep you from getting 100%.
MPREZYA is offline   Reply With Quote
Old 10-24-2000, 03:07 PM   #4
Pipercub
Scooby Specialist
 
Member#: 2188
Join Date: Aug 2000
Location: Remington VA`
Vehicle:
2004 Impreza STI
82 BRAT with 12 in. lift

Post

It was something simple, but not as simple as a floor mat. I performed an initialization on the SAFC and set it up with the same settings as I did the first time and 100% throttle is now displayed. SO, to anyone installing an SAFC, do an initialization, then input your settings for sensor type # of cyl etc. It takes 10 seconds and saves you a great deal of trouble.
Pipercub is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[DISCOUNT] Get 10% off on wheel & tire combos from TireBuyer.com PostRelease Tire & Wheel 0 06-01-2010 01:01 PM
Engine misses when throttle 'floored' lil'greenimp_98 Service & Maintenance 3 02-11-2008 12:36 PM
engine missing after 50% throttle kolohe Engine Management & Tuning 23 12-19-2004 03:09 PM
I think my SAFC just went to SAFC heaven... Fred Zaplitny Engine Management & Tuning 3 03-25-2003 09:12 AM
('93-'01) SAFC Throttle not reading "zero" 2yLiTe Impreza Forum 12 04-12-2001 12:33 AM


All times are GMT -4. The time now is 01:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.