Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-14-2001, 10:32 PM   #1
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Question Turbo's & Cruise Control==>Compatible?

IIRC, most of the existing aftermarket turbo systems out there that are using intercoolers have to remove the cruise control. Is this correct?

I drive many thousands of kilometers/miles a year and to lose my cruise would completely suck!!!

Any of you turbo owners care to comment on what modifications (if any) you had to make to your cruise control in order to make this work? Or did you simply live with the inconvienence?

Your input appreciated.
* Registered users of the site do not see these ads.
markus is offline   Reply With Quote
Old 02-14-2001, 10:46 PM   #2
AaronB
Worst Mod Ever
Moderator
 
Member#: 369
Join Date: Oct 1999
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
12 Vagon

Post

You just have to relocate it. You need to move it more because of where the turbo mounts, rather than the IC. Here is a pic of where I put mine.

<IMG SRC="http://www.azscooby.com/images/Rim00023.jpg" border=0>

It is the green/black thing above the air filter (for those who might not know what they are looking for.)

Hope this helps,

Aaron
http://www.azscooby.com
AaronB is offline   Reply With Quote
Old 02-14-2001, 11:58 PM   #3
XT6Wagon
Scooby Specialist
 
Member#: 524
Join Date: Nov 1999
Location: WA
Vehicle:
04 STi
White

Post

Oh, you might want to put on stronger throttle return springs...

My Turbo wa on the highway when a car passed me and pulled back in. Bingo the car accelerates as the air drag decreases ALOT (hmm 4X4 ride hight and areodynaics of a barn). Well this causes the turbo to spool. The turo is spolling faster than the cruise can let off on the throttle. So here I am accelerating hard at 85MPH running 15psi and the boost is holding the TB open, as the cruise is resisting the throttle return spring enough.

XT6Wagon is offline   Reply With Quote
Old 02-15-2001, 12:01 AM   #4
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2013 B9 Tribeca LTD
2005 Impreza 2.5 RS

Post

Here is my relocated Cruise Control near the ABS - Instructions are posted off the mymods section of my website www.ImprezaRS.com. No problems so far.

<IMG SRC="http://www.imprezars.com/images/step160dcp00365.jpg" border=0>

Larry

[edit] typed a / after the www in the URL instead of period for the picutre

[This message has been edited by ImprezaRS dot com (edited February 15, 2001).]
ImprezaRS dot com is offline   Reply With Quote
Old 02-15-2001, 01:25 AM   #5
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Post

Yup, cruise control isn't a problem Markus.

Had I kept my turbo I would've mounted it back somewhere else too...I can't live without my ABS!

Fwiw, I think not having the cruise control was what was setting off my AT oil temp light back then.
Keiho is offline   Reply With Quote
Old 02-15-2001, 05:37 PM   #6
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Thumbs up

Thanks for your input guys. Looks like its a no-brainer modification.
markus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog light & cruise control switch smokeone954 Private 'Wanted' Classifieds 2 04-15-2010 02:18 AM
06 STI Differential & Cruise control prob from LED tail light bulbs REDDOG Drivetrain 0 05-02-2008 06:20 PM
Aftermarket Steering wheel & Cruise Control? WAYGONE1 Motorsports 5 06-04-2007 05:20 PM
HELP! Check Engine light on & Cruise Control Light Blinking STiURBO Southern California Impreza Club Forum -- SCIC 21 03-15-2007 01:54 AM
Steering wheel & Cruise control Skeandhu Interior & Exterior Modification 6 01-23-2001 08:08 AM


All times are GMT -4. The time now is 08:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.