Welcome to the North American Subaru Impreza Owners Club Wednesday June 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-17-2012, 01:02 PM   #1
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default Girlfriend's Forester A/C Compressor

Can anyone provide me with a how to for replacing this? I'm sure it's the same as the Impreza or at least very close.

It's whining extremely loud.
* Registered users of the site do not see these ads.
maw230 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-17-2012, 01:11 PM   #2
Tomato_88
Scooby Newbie
 
Member#: 204277
Join Date: Feb 2009
Location: Central California
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

Have you checked the pressure? Does it have enough oil/refrigerant
Tomato_88 is offline   Reply With Quote
Old 05-17-2012, 01:12 PM   #3
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default

Yes, I added plenty more until it was at the correct pressure. It worked for a very short spell then just went back to whining like mad.

I'm going to change the belt first and see if that helps.
maw230 is offline   Reply With Quote
Old 05-17-2012, 01:26 PM   #4
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: ლಠ益ಠ&
Default

Does it work besides the noise?
GrundleJuice is online now   Reply With Quote
Old 05-17-2012, 01:28 PM   #5
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default

No, it did for a very short time. Maybe a drive or two around the block before the noise and lack of cold air returned.
I'm going to replace the belt and re-check the pressure to see if I have a leak, but if that is not the case, I would love to find instructions on how to change it.
maw230 is offline   Reply With Quote
Old 05-20-2012, 08:11 PM   #6
Rudgers73
Scooby Newbie
 
Member#: 141433
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Rochester, NY
Vehicle:
2006 Impreza 2.5i
Obsidian Black

Default

If it worked for a while, then stopped I'd say you probably have a leak somewhere. If the belt needed changing then refilling the refrigerant probably wouldn't have done anything for you
Rudgers73 is offline   Reply With Quote
Old 05-21-2012, 02:07 PM   #7
FPS_Bloodline
Scooby Newbie
 
Member#: 314552
Join Date: Mar 2012
Chapter/Region: NESIC
Location: Northford, Connecticut
Vehicle:
2011 Impreza
Spark Sliver

Default

i say add so leak stop to the ac system first and see if that helps, if not find the leak, it could be your baring seal if thats the case then you need a new ac compressor for sure
FPS_Bloodline is offline   Reply With Quote
Old 05-21-2012, 02:10 PM   #8
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default

Thanks guys, I'll start by leak checking after I change the belt.
maw230 is offline   Reply With Quote
Old 05-29-2012, 09:06 AM   #9
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default

Changed the belt and added some leak stop r134a. It's working well for now
maw230 is offline   Reply With Quote
Old 05-29-2012, 10:10 AM   #10
NitroTrike
Scooby Specialist
 
Member#: 62408
Join Date: May 2004
Chapter/Region: South East
Location: GWR, Florida
Vehicle:
2002 wrx w/ STi guts
174k miles on Mobil 1

Default

Quote:
Originally Posted by maw230 View Post
Yes, I added plenty more until it was at the correct pressure. It worked for a very short spell then just went back to whining like mad.

I'm going to change the belt first and see if that helps.
Just stop and close the hood before you hurt yourself or someone around you. Seriously.
NitroTrike is offline   Reply With Quote
Old 05-29-2012, 10:12 AM   #11
maw230
Scooby Newbie
 
Member#: 277632
Join Date: Mar 2011
Chapter/Region: MWSOC
Vehicle:
2005 Impreza Wagon

Default

Awesome advice, scro. Keep up the good work.
maw230 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Group Buy (2012): 2007~2008 Forester XT Front Lip (Carbon Fiber) RavSpec RavSpec 73 04-18-2014 10:17 PM
FS/FT : LA/TX: 2002 Subaru Forester S Premium NEEDS A GOOD HOME tad_07 South East Region Private Classifieds 10 07-24-2012 06:45 PM
WTB: AC Compressor and Forester XT Radiator AaronB SWIC Private Classifieds 12 07-10-2007 03:12 AM
WTB: AC Compressor and Forester XT Radiator AaronB Private 'Wanted' Classifieds 0 07-02-2007 08:43 PM
wtb forester ac compressor LA Private 'Wanted' Classifieds 6 08-05-2005 10:02 PM


All times are GMT -4. The time now is 08:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.