Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-22-2004, 03:01 AM   #1
SBasinger18
Scooby Newbie
 
Member#: 37576
Join Date: May 2003
Location: Riverside, CA
Vehicle:
2008 EVO X, '09 WRX
Wicked White, SWP

Default Check Engine light w/ flashing Cruise Light?

I have Check Engine light w/ flashing Cruise Light, what does this mean?

my mods are as follows:

Invidia Cat-back
Invidia Downpipe
Zero/sports intake pipe
Blitz SUS
HKS up-pipe
HKS Header
HKS BOV
Greddy FMIC
* Registered users of the site do not see these ads.
SBasinger18 is offline   Reply With Quote
Old 07-22-2004, 09:18 AM   #2
sneeky
Scooby Specialist
 
Member#: 44639
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: They say it's the armpit...
Vehicle:
STi
the 35 awaits you...

Default

could be a few different things, especially with that front mount on there with stock turbo. when did it happen? most common with the STi is fuel cut from boost creep from your exhaust... don't forget the search button


chris
sneeky is offline   Reply With Quote
Old 07-22-2004, 10:41 AM   #3
TexRex2002
Scooby Specialist
 
Member#: 36303
Join Date: May 2003
Chapter/Region: TXIC
Location: Houston
Vehicle:
06 Evo IX
silver

Default

on WRX's that usually meant that the green connectros under the driver's side dash were connected (and shouldn't be). They are used only for diagnostics.

Check to see if that might be the problem. They should not be connected.
TexRex2002 is offline   Reply With Quote
Old 07-22-2004, 10:58 AM   #4
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

Quote:
Originally Posted by TexRex2002
on WRX's that usually meant that the green connectros under the driver's side dash were connected (and shouldn't be). They are used only for diagnostics.

Check to see if that might be the problem. They should not be connected.
On the sti whenever you get a CEL the CC is disabled and the light flashes.
Have the code pulled at an autozone. Or buy a code scanner at sears(~$100) with those mods I have a feeling that you will need it often.

TMS
TheMadScientist is offline   Reply With Quote
Old 07-22-2004, 12:09 PM   #5
WRX Jim
Scooby Specialist
 
Member#: 22321
Join Date: Aug 2002
Location: Germantown MD
Default

sounds like emmision codes popping from the exhaust
WRX Jim is offline   Reply With Quote
Old 07-22-2004, 01:26 PM   #6
White out
Scooby Guru
 
Member#: 46277
Join Date: Oct 2003
Chapter/Region: SCIC
Location: Michigan
Vehicle:
** Ring Time of
7:40

Default

Rear 02 sensor. I have almost the same set up FMIC, header, up, down, cat back, utec, and mine keeps goin off for the rear 02. Gruppe-S sells cel fix's for $15. Get one and your CEL should go away.
For the flashing cruise thing.
1. It pisses me off
2. It is a way for Subaru to make cash when the car gets old. Because not being able to use cruise will drive you nuts, then you have to take it in to get it fixed.

Nick
White out is offline   Reply With Quote
Old 07-22-2004, 01:28 PM   #7
jasonhunt007
Scooby Newbie
 
Member#: 51054
Join Date: Dec 2003
Location: marietta, ga
Vehicle:
2004 subaru
black

Default

try to disconnect the battery to reset the ecm...
jasonhunt007 is offline   Reply With Quote
Old 07-22-2004, 01:59 PM   #8
wm07
Scooby Newbie
 
Member#: 26529
Join Date: Oct 2002
Location: STU
Vehicle:
04 STi
White

Default

Get the code pulled, otherwise, all the response are just guesses...
wm07 is offline   Reply With Quote
Old 07-23-2004, 07:00 PM   #9
zacek
Scooby Specialist
 
Member#: 19467
Join Date: May 2002
Location: Chatsworth, CA.
Vehicle:
02 WRX
WR Blue

Default

I'm 90% sure is your Invidia Downpipe.

My friend has it on a STi and has the exact same symptom.

I have the APS Turbo-Back and not porblems at all. There seems to be something funny about the position of the rear O2 sensor on the Invidia downpipe.
zacek is offline   Reply With Quote
Old 07-23-2004, 07:15 PM   #10
akirasan
Scooby Newbie
 
Member#: 45158
Join Date: Oct 2003
Location: Bay Area
Vehicle:
2004 STi
WRB

Default

Most popular/simple reason for throwing a cell and the flashing cruise: something amiss with the fuel/EC system. Loose/cross-threaded gas cap, EC hoses accidentally knocked off when crawling underneath the rear of the car (exhaust/suspension install).

YMMV
akirasan is offline   Reply With Quote
Old 07-23-2004, 07:16 PM   #11
V6TurboTA
Scooby Guru
 
Member#: 9090
Join Date: Aug 2001
Location: < of Boston
Vehicle:
09 Forester Gump
02WRX->04STi->09Gump

Wink

Quote:
Originally Posted by TheMadScientist
On the sti whenever you get a CEL the CC is disabled and the light flashes.
Have the code pulled at an autozone. Or buy a code scanner at sears(~$100) with those mods I have a feeling that you will need it often.

TMS
lol what makes you say that? I only needed to borrow your scanner twice... (so far)

~v6
V6TurboTA is offline   Reply With Quote
Old 07-24-2004, 12:55 AM   #12
WRX Jim
Scooby Specialist
 
Member#: 22321
Join Date: Aug 2002
Location: Germantown MD
Default

get the mechanical fix.. i have it works like a charm
WRX Jim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light and Flashing Cruise Control Light moose00015 Newbies & FAQs 17 05-29-2011 10:16 PM
check engine light and flashing cruise? 04wrexsti Tri-State Area Forum 11 12-29-2009 08:06 PM
Check Engine light W/ flashing cruise control? parad0x Newbies & FAQs 6 05-24-2008 02:18 AM
Check Engine light W/ flashing cruise control? LiDrummer Newbies & FAQs 39 07-09-2007 01:56 PM
check engine light w/ flashing cruise control STi in ur face Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 7 08-22-2006 10:34 PM


All times are GMT -4. The time now is 10:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.