Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-23-2004, 09:33 PM   #1
grantn
Scooby Newbie
 
Member#: 25398
Join Date: Sep 2002
Location: Los Angeles, CA
Vehicle:
2005 STi
WRB

Default Cel P0102

found problem

ThanX
* Registered users of the site do not see these ads.

Last edited by grantn; 08-15-2004 at 08:17 PM.
grantn is offline   Reply With Quote
Old 07-24-2004, 12:01 AM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

P0102 Mass air flow sensor circuit low input

Sounds like that perrin maf is borked. try unplugging the maf and see if the car runs, it will cut out at 4500 rpm though with the maf disconnected.

Jay
munkis is offline   Reply With Quote
Old 07-24-2004, 03:27 AM   #3
grantn
Scooby Newbie
 
Member#: 25398
Join Date: Sep 2002
Location: Los Angeles, CA
Vehicle:
2005 STi
WRB

Default

It's the same with the maf unpluged.
grantn is offline   Reply With Quote
Old 07-24-2004, 03:13 PM   #4
sonxwrx
Scooby Newbie
 
Member#: 35781
Join Date: Apr 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
2011 STI
Spark Silver Metallic

Default

I researching the same CEL code - P0102.

I was having the same problems with starting the car. Actually I was driving on a local street when suddenly the car shut off.

I have an 03 WRX sedan with a PDE uppipe and RSR turboback (80mm piping). I have the stock intake setup and stock BOV.

P0102 Mass air flow sensor circuit low input
Seems like there a leak some where ... I'm investigating now but cant tell. Managed to get the car started after resetting the ecu and just letting the car crank the ignition until it starts. Then I just drove it home.

Same problem occurred July 4th evening while trying to drive home. It was raining alot then and last night as well.

I hope my info helps.
sonxwrx is offline   Reply With Quote
Old 07-24-2004, 06:39 PM   #5
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Check for vacuum leaks. specifically your intercooler hoses, see if one blew off.

Jay
munkis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL code P0113 and P0102 together kingtut12 Factory 2.0L Turbo Powertrain 30 06-22-2014 01:58 AM
I have a CEL that reads p0102 SUBYS R US Rocky Mountains Impreza Club Forum -- RMIC 8 01-19-2009 06:04 PM
P0102 and P0113 CELs KB21 Newbies & FAQs 8 11-11-2008 11:02 AM
UTEC 5.0 and CEL code P0102 AURAz UTEC 16 08-18-2006 01:55 PM
CEL codes P0102 and P0103 both NITROS Service & Maintenance 6 11-15-2005 06:13 PM


All times are GMT -4. The time now is 03:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.