Welcome to the North American Subaru Impreza Owners Club Monday August 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-31-2004, 04:25 PM   #1
Subie123Poot
Scooby Newbie
 
Member#: 67364
Join Date: Jul 2004
Location: Orlando
Vehicle:
2005 STI
Aspen White

Default Up pipe and catback= loss of power

I have installed a HKS up pipe and a Tanabe Ultra Medallion cat back exhaust on a 2004 WRX. Ran at the track and couldnt do better than a 15.3. I ran under that in my civic si. No exhaust leaks before or after the turbo. Is the cat back exhaust the cause for the feeling of power loss from 2500 to 5000. Any suggestions for the next step. I need more power captain.
* Registered users of the site do not see these ads.
Subie123Poot is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-31-2004, 10:49 PM   #2
bofh
Scooby Specialist
 
Member#: 59287
Join Date: Apr 2004
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2007 WRB WRX
2004 WRB WRX (RIP)

Default

Quote:
Is the cat back exhaust the cause for the feeling of power loss from 2500 to 5000.
What power loss? These engines don't have power until 4000. Try driving in the power band and see if it gets better.
bofh is offline   Reply With Quote
Old 08-01-2004, 09:50 AM   #3
rexster
Scooby Specialist
 
Member#: 22863
Join Date: Aug 2002
Chapter/Region: MAIC
Location: The Land of Mary
Vehicle:
2015 WRX Premium CWP

Default

wrong forum. this should be in the Factory 2.0 Turbo forum.

i don't see how adding the upipe and cat back could have made the car slower. Are you using the stock downpipe? If you are then i wouldn't expect any noticable gain from those mods. You're still choked after the turbo...
rexster is offline   Reply With Quote
Old 08-01-2004, 11:02 AM   #4
SGOSWRX
Scooby Specialist
 
Member#: 10921
Join Date: Oct 2001
Location: S.W. Florida
Vehicle:
04 04 STi
12.8 @ 105 mph

Default

Quote:
Originally Posted by rexster
wrong forum. this should be in the Factory 2.0 Turbo forum.

i don't see how adding the upipe and cat back could have made the car slower. Are you using the stock downpipe? If you are then i wouldn't expect any noticable gain from those mods. You're still choked after the turbo...

As mentioned above. Don't expect big power gains from an uppipe and catback exhaust - without upgrading your downpipe.

A good question would be what did your WRX run stock? Also let us see what your time slip looks like. If your running slow 60' times, that would explain your slow 1/4 mile times.

I've seen guys with stage 4 WRX's (270 whp) run 14s in the 1/4 mile. So its not always the car. In most cases its the driver.
SGOSWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud ticking turbo and major loss of power? lordizzy626 Newbies & FAQs 8 04-09-2010 06:32 PM
Loss of power and takes a while to start up swiftwrx06 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 06-27-2007 05:56 PM
Adding a Resonator in Catback = Loss of Power?? Inprogress Texas Impreza Club Forum -- TXIC 13 06-17-2005 05:05 PM
Looking to buy up pipe and catback hotshot172 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 05-16-2005 06:10 PM
Loss Of Power & Sucking Sound While Spool Up??help??? HezWrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 12-18-2003 07:55 PM


All times are GMT -4. The time now is 11:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.