Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-03-2004, 10:44 PM   #1
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Question AVC-R Help!!

I just installed the AVC-R. Everything went well, no problems. Decided not to hook up the boost solenoid until I felt everything was running right. Hooked up the solenoid today. As soon as I turned the car on CEL went on. Any help w/ this? Why did it go on?

S.V.133
* Registered users of the site do not see these ads.
S.V.133 is offline   Reply With Quote
Old 08-04-2004, 09:56 AM   #2
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

Anyone?
S.V.133 is offline   Reply With Quote
Old 08-04-2004, 10:56 AM   #3
big_adventure
Scooby Specialist
 
Member#: 40501
Join Date: Jul 2003
Location: Paris, FR
Vehicle:
2005 Decathalon 21sp
One WheelSeanPower

Default

Get the code pulled, but it's probably a wastegate solenoid low/high input CEL. Autozone pulls codes for free.
big_adventure is offline   Reply With Quote
Old 08-04-2004, 11:59 AM   #4
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

Thanks. If it's the wastegate solenoid input CEL, does that mean the duty % needs to be corrected?

Thanks for the help
S.V.133 is offline   Reply With Quote
Old 08-04-2004, 09:43 PM   #5
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

Going to Autozone tomorrow. First atempt there, no good. Only 1 person knows how to use the data logger.
S.V.133 is offline   Reply With Quote
Old 08-05-2004, 04:48 PM   #6
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

OK, the CEL code was (Wastgate Solenoid) Right now I have the duty set at 50%.
S.V.133 is offline   Reply With Quote
Old 08-06-2004, 05:14 AM   #7
Big Turkey
Scooby Specialist
 
Member#: 32118
Join Date: Jan 2003
Location: Houston, TX
Default

What did it say about the solenoid? The AVCR has it's own solenoid so it completely bypasses the stock one. you can just unhook it call it a day. I have mine hooked up to my ABC right now and capped off.. only because I'm too lazy to take it completely off, haha.
Big Turkey is offline   Reply With Quote
Old 08-06-2004, 10:21 AM   #8
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

So, your saying I can cap off the line on the wastgate solenoid of the turbo? Right now have the line on the inlet pipe tapped off. It "T" to the turbo and than into the factory boost solenoid.
S.V.133 is offline   Reply With Quote
Old 08-06-2004, 10:22 AM   #9
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

The code was a P0250, I believe (Wastgate Solenoid) Adjusting the duty right now wont help at all.
S.V.133 is offline   Reply With Quote
Old 08-06-2004, 11:26 AM   #10
cdvma
Scooby Specialist
 
Member#: 21980
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2002 PSM WRX (Sold)
2009 BMW X5

Default

When using the independent solenoid of the AVCR you have to leave the stock one attached to the car, the ECU will freak out if it cant talk to it. Just plug the lines that go to/from it and leave it in the car.
cdvma is offline   Reply With Quote
Old 08-06-2004, 12:19 PM   #11
big_adventure
Scooby Specialist
 
Member#: 40501
Join Date: Jul 2003
Location: Paris, FR
Vehicle:
2005 Decathalon 21sp
One WheelSeanPower

Default

That's the CEL - it's mad that you disconencted the stock solenoid. You can just plug it, but leave it there!

-Sean
big_adventure is offline   Reply With Quote
Old 08-06-2004, 09:35 PM   #12
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

Thanks everyone. I spoke to a friend who has the AVC-R, he told me to do the same. Now I just have to learn to fine tune it.
S.V.133 is offline   Reply With Quote
Old 08-06-2004, 11:30 PM   #13
S.V.133
Scooby Newbie
 
Member#: 44166
Join Date: Sep 2003
Vehicle:
2003 WRX
Midnightblack

Default

No More CEL!!!!!!!
S.V.133 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HR: Need AVC-R help! SupraScooby Mid Atlantic Impreza Club -- MAIC 6 09-10-2005 02:36 PM
AVC-R Help vvRX7 North West Impreza Club Forum -- NWIC 1 01-17-2005 01:59 AM
AVC-R help... raykwok Engine Management & Tuning 0 01-05-2005 12:45 PM
avc-r help requested. kcwrx02 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 12-03-2002 07:14 PM
Apex-i AVC-R...Help! fastnoypi Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 06-05-2001 08:45 PM


All times are GMT -4. The time now is 02:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.