Welcome to the North American Subaru Impreza Owners Club Monday September 15, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-07-2004, 12:42 PM   #1
WRXout
Scooby Specialist
 
Member#: 52908
Join Date: Jan 2004
Location: Houston, on highway 6
Vehicle:
2005 WRX STI FTI 20G
ASPEN WHITE

Default to laggy

well its heres my deal i got a ecu flash from kingpin , and map clark a.k.a azscoobie built me. as it hits boost the car start to kick then when it hits 4500rpms it hauls ass..

i have a 4eat, automatic tranny.

my mods:
+EcuTek
+Perrin FMIC**
+565cc Sti Injectors
+Walbro 255lph Fuel Pump
+IHI VF30
+helix upipe
+invidia downpipe
+blitz full racing catback exhaust
+Perrin Lightened Crank Pulley
+HKS SSQV

my ecu tek is sort of a custom map but didnt get to play with it on the dyno, he built one map could falsh the ecu, so i boguht an ecu from kingpin and he flashed it..

i put a star next to perrin fmic cause i was thinknig maybe thats why it lags so bad but has killer topend!

its 100ferenhiet her in houston and 80% humid, is this why? think c02 spray to the intercooler will fix my problem?
* Registered users of the site do not see these ads.
WRXout is offline   Reply With Quote
Old 08-07-2004, 01:07 PM   #2
Newbie Subie
Scooby Specialist
 
Member#: 20214
Join Date: Jun 2002
Chapter/Region: SCIC
Location: Ventura, CA
Vehicle:
07 Acura RDX
390WHP no more

Default

I have an almost identicle setup as yours as of yesterday.... but no reflash/manual/TMIC

SR40 now but....

Based on my knowledge that I have had the VF30 combination for over 50000 miles I can say that something is a little messed up my VF 30 kicks in hard at around 2800-3000 RPM. The VF30 should spool much earlier than 4500 RPM even with the FMIC. Do yourself a favor and buy DeltaDash and do some logs. Send them back to Clark and have him adjust it.

With DeltaDash you can load in the new map that he provides you without sending the ECU back.

As far as O2 spray, I doubt it will have any effect on your spool, may run a bit cooler and aide in knock supression.
Newbie Subie is offline   Reply With Quote
Old 08-09-2004, 12:19 AM   #3
Kingpin
Vendor
 
Member#: 41252
Join Date: Aug 2003
Chapter/Region: SWIC
Location: 602-795-3036
Vehicle:
Twin 2005 600WHP
FormulaD/TimeAttack Sti's

Default

Yeah it still seems a bit laggy to me. Some logs would be great if you have them. Bosst leak is most common cause of lag that we see. Might want to recheck all of your FMIC pipes. Even a small leak can cause considerable lag. The FMIC has some effect but I would exspect it to be on ealrier than it is. Let me know so that we can help sort this out. Thanks.
Kingpin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GM to invest $245 million to build a new six-speed transmission AVANTI R5 Non-Subaru News & Rumors 12 06-07-2010 07:25 AM
vf22 is it to laggy wrxracer3 Factory 2.0L Turbo Powertrain 4 07-16-2004 10:40 PM
laggy boost SM DONK Southern California Impreza Club Forum -- SCIC 5 11-20-2002 04:22 PM
question for vf30 and laggy turbo owners datdudedennis Factory 2.0L Turbo Powertrain 6 10-28-2002 03:17 PM
Shifting a high power laggy turbo car... d00f Transmission (AT/MT) & Driveline 3 01-08-2002 08:49 PM


All times are GMT -4. The time now is 11:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.