Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2004, 06:04 PM   #1
Bubba G
Scooby Newbie
 
Member#: 63100
Join Date: Jun 2004
Chapter/Region: VIC
Location: Vancity
Vehicle:
2002 WRX Aspen White
Stg 2

Default Coolant Reservoir Levels

I dunno if the hot temperature in Vancouver this summer has led to the low levels in my coolant reservoir lately. I washed my car about a month ago and I popped up the hood and checked both oil and coolant. I noticed the levels of the coolant reservoir was at L, so I filled it up with premix to F. Today I washed my car again and did the same and the level was at L again! I'm wandering if this is a normal occurence for turbo cars in this heat? I'm just hopping this is normal for the WRX and its not my head gasket going.
* Registered users of the site do not see these ads.
Bubba G is offline   Reply With Quote
Old 08-15-2004, 10:38 PM   #2
KIMUTAKU
Scooby Specialist
 
Member#: 19776
Join Date: Jun 2002
Chapter/Region: VIC
Location: Vancouver, Canada
Vehicle:
2012 GVF SWP
Ninja Lime Green

Default

specialty told me this is normal.. the level in the reservoir tank varies..

i also had the same "problem".. i thought i was losing coolant somewhere, but i guess it's nothing to worry about..
KIMUTAKU is offline   Reply With Quote
Old 08-15-2004, 11:19 PM   #3
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Burnaby, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Default

Did you check at least your radiator is full?
Ken is offline   Reply With Quote
Old 08-16-2004, 04:09 AM   #4
Necromancer
Scooby Specialist
 
Member#: 477
Join Date: Oct 1999
Location: Vancouver
Vehicle:
GC4 -> GGA -> GM6
Yeah, that's about right.

Default

Look under the car for signs of fluid leakage (crusty green stuff). Mine has a slow leak from one of the head gaskets, despite putting in the Subaru coolant conditioner. Need to get that fixed under the warranty..
Necromancer is offline   Reply With Quote
Old 08-16-2004, 03:02 PM   #5
Bubba G
Scooby Newbie
 
Member#: 63100
Join Date: Jun 2004
Chapter/Region: VIC
Location: Vancity
Vehicle:
2002 WRX Aspen White
Stg 2

Default

I'm pretty sure the coolant levels are full, b/c I performed the 48k maintenance recently and did a radiator flush and fill.

No green crusty's from the to at least, I better jack her up and take a peek at the bottom..........hopefully its just the hot temp (keeping finger's crossed)

So how would I know if the head gasket is blown or not?
Bubba G is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 02-05 intercooler, aftrmrkt y-pipe, metal coolant reservoir, radiator/coolant cap iheartmysuby Engine/Power/Exhaust 17 10-21-2009 01:32 PM
i need a coolant reservoir that will fit my 99rs White 2.5rs North West Impreza Club Forum -- NWIC 4 07-04-2004 02:17 PM
Used 2002 WRX coolant reservoir IA Performance Private 'For Sale' Classifieds 1 03-24-2004 05:16 PM
concerns about the coolant reservoir Benjamin Tang Factory 2.0L Turbo Powertrain 76 10-01-2003 06:45 PM
WRX, STI Coolant reservoir IA Performance Private 'For Sale' Classifieds 5 09-29-2003 12:22 PM


All times are GMT -4. The time now is 04:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.