Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-22-2004, 09:26 AM   #1
loscooby
Scooby Newbie
 
Member#: 34096
Join Date: Mar 2003
Vehicle:
2002 Impreza STI
Micra blue

Default cel P0244 today

Calling all techies!

I have had my euro spec STI -2003 ECUTEK'ed along with a full aftermarket exhaust(1 race cat in center decat downpipe)

I got the cel the other day, my obdII scanner read:
P0244 -Wastegate control solenoid valve malfunction (high input)

The cel came up on the highway in 6th gear, wot while overtaking then I hit fuel-cut and a loud bang was heared from what appeared to be the back of the exhaust...

The car still pulls like normal but there is a burbling sound in the rpm-range 3500 to about 4000, sounds like the turbo or engine is choking or something.

I hear the normal turbo-whining until this rpm-range but it transforms into this strange sound.

I should add the burbling sound is less notable when the engine is colder...

I called my tuner and he says it could be the wastegate??

What do you guys reccon, air-pipe leak, turbo failure ??

/L-O
* Registered users of the site do not see these ads.
loscooby is offline   Reply With Quote
Old 08-22-2004, 11:04 AM   #2
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

P0244 is the boost cut code. It's possible that you broke something when you hit this hard cut. Sorry I can be of no more help.
mick_the_ginge is offline   Reply With Quote
Old 08-22-2004, 11:33 AM   #3
loscooby
Scooby Newbie
 
Member#: 34096
Join Date: Mar 2003
Vehicle:
2002 Impreza STI
Micra blue

Question

Please you techies out there...
loscooby is offline   Reply With Quote
Old 09-11-2004, 10:57 PM   #4
Kushmasterh
Scooby Newbie
 
Member#: 70027
Join Date: Sep 2004
Location: Bel Air Subaru/Nissian Club
Vehicle:
2004 WRX STi
Platinum Silver

Subaru Stars CEL At High Speed

I have also experinced this but just with out the loud banging sound. I own a 2004 GDB STi and have been told some things about overboosting and boost lag, but no real solution yet. Installed myself Helix 3" blemouth downpipe w/ cat-back exhaust, APS cold air, HKS SSQV bolw-off. At around 90-100 in 5th the fuel cut-off hits and the car just sort of dies. CEL comes with crusie blinking. The scanner reads the same code. P0244.(Turbo wastegate control soleniod valve malfunction, High Input) HELP!
Kushmasterh is offline   Reply With Quote
Old 09-12-2004, 11:33 AM   #5
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

i have experienced this code as well but f course without the bang and choking afterwards. I had a cheap MBC that was sticking and causing me to overboost. After clearing code everything was fine, i never really got on the car with the CEL on so for the choking i am not accountable for, but i also have stock TB Exhaust. Reset the ECU using a scanner if you can and drive the car to see if it is ok. mine was and still is.
REDI-wgn is offline   Reply With Quote
Old 09-12-2004, 11:36 AM   #6
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

forgot to mention that when putting turbo back exhaust on STi,s there is a big chance of overboost becasue the wastegate cannot flow enough air through it causing more air to flow through turbo hence the overboost. Friends of mine have had to get their wastegate ported when puttin downpipes on their STi`s. Do a search cause i am sure this was discussed in great detail before and you will get alot more iinfo on it that i can give you.
REDI-wgn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL P0244??? Turbo wastegate problem stcktnkid Factory 2.0L Turbo Powertrain 4 08-11-2010 10:31 AM
CEL P0244 Again (hopefully different) serendipity Engine Management & Tuning 3 12-22-2004 12:29 PM
CEL P0244 and TurboXS ABC rainmanjam Engine Management & Tuning 1 09-28-2004 12:11 PM
CEL P0244 - Wastegate out of range? Big Turkey Engine Management & Tuning 2 09-04-2003 12:33 AM
CEL P0244, can someone explain? bdowell Factory 2.0L Turbo Powertrain 2 10-22-2001 12:47 PM


All times are GMT -4. The time now is 04:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.