Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-01-2004, 12:06 AM   #1
RallyFord
Scooby Newbie
 
Member#: 47699
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: Ankeny
Vehicle:
2012 STI Wagon
Dark Grey Metallic

Question Air conditioner not working - AT ALL.

I was wondering if anyone else has had a problem with their air conditioning quitting. I know about the "icing" problems and had started to experience that issue on hot humid days this summer. Just recently, however, I was away on business for a week, away from my beloved Subaru, and came back to drive it and found that the air conditioner wasn't working AT ALL. It was never that great in the first place, but now when you push the air conditioner button with the fan on, it doesn't do anything. It used to make the engine idle higher to run the compressor and such, but it doesn't make any kind of noise and doesn't affect the engine idle at all. Any suggestions as to what may be causing the problem?

2003 WRX - 34400 miles, just barely under warranty yet thankfully.
* Registered users of the site do not see these ads.
RallyFord is offline   Reply With Quote
Old 09-01-2004, 07:04 AM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

Since it's under warranty, just bring it in to the dealership - it could be a number of things, ranging from a dead compressor to a leak which discharged the system to some sort of electrical issue.
DrD is offline   Reply With Quote
Old 09-01-2004, 07:39 AM   #3
rogue
Teddy Goalsevelt
Super Moderator
 
Member#: 7977
Join Date: Jul 2001
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
100% Abuse

Default

Yeah, it's broken... my 02 with 45k miles still blows cold air just fine, no reason yours should be dead.
rogue is offline   Reply With Quote
Old 09-01-2004, 07:58 AM   #4
Calamity Jesus
Scooby Guru
 
Member#: 44501
Join Date: Oct 2003
Chapter/Region: South East
Location: in a minefield of caddishness.
Vehicle:
1984 "Skeletor from
"He-Man"

Default

Quote:
Originally Posted by RallyFord
It was never that great in the first place, but now when you push the air conditioner button with the fan on, it doesn't do anything. It used to make the engine idle higher to run the compressor and such, but it doesn't make any kind of noise and doesn't affect the engine idle at all. Any suggestions as to what may be causing the problem?

2003 WRX - 34400 miles, just barely under warranty yet thankfully.
Checked the fuse yet?
Calamity Jesus is offline   Reply With Quote
Old 09-01-2004, 08:00 AM   #5
Odin
Scooby Newbie
 
Member#: 25428
Join Date: Sep 2002
Location: East Coast
Vehicle:
2005 STi

Default

Sounds like a leak in your system. I say this because you were away for two weeks. This exact same thing happened on another car of mine. If you are under warranty go to the dealer. The may run one of those UV tests to check for leaks. If it is a pinhole they won't find it. If you feel like it go buy a couple cans of refrigerant and put them in.
Odin is offline   Reply With Quote
Old 09-01-2004, 08:03 AM   #6
RallyFord
Scooby Newbie
 
Member#: 47699
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: Ankeny
Vehicle:
2012 STI Wagon
Dark Grey Metallic

Default

beaverboy - thanks, didn't even think to check the fuse

rogue, drd, odin - thank you for the advice, I'll be using it all =)
RallyFord is offline   Reply With Quote
Old 09-01-2004, 10:28 AM   #7
aerofan897
Scooby Newbie
 
Member#: 61143
Join Date: May 2004
Location: Minneapolis, MN
Vehicle:
03 Cobb Stg II WRX
WR Blue

Default

Mine hadn't worked since I got the car (although I didnt notice it until summer). Turns out there was a faulty "pressure sensor" for the AC somewhere, and that had to be replaced. The subie mechanic said that if that sensor is easy to mess up on installation, so I guess he's done a few... Subie dealership will know best.
aerofan897 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Conditioner Not Working seanr2 Baja Forum 8 05-15-2009 03:09 PM
Rear defroster not working at all silence2-38554 Electrical & Lighting 9 03-06-2009 12:49 PM
I installed a SATA Raptor drive, why does my IDE CDROM run slow/not work at all? White 2.5rs Off-Topic 17 06-07-2006 11:46 AM
air conditioner not working FinalBean Service & Maintenance 5 04-27-2004 07:53 PM
Overdoing ground mod will cause it to not work at all! d4d4d4d4 Electrical & Lighting 4 07-14-2003 04:25 PM


All times are GMT -4. The time now is 05:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.