Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-19-2004, 08:25 PM   #1
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Smile My Cobb Stage 2 Dyno #'s and Boost Question

I put down 220/220 on Ultimate Performance's Dynojet on Saturday (scan of the dyno plot is soon to come). According to the A/F ratios measured at the dyno, I'm running extremely rich. I think there is more power that could be extracted from this setup, but right now it's running safe.

I'm running the Cobb Stage II 91 Octane Map

Borla Header
STi Uppipe
Stock Turbo
Stock BPV
Samco IC Hoses
Godspeed Downpipe
SPT Catback

I am seeing a boost max of around 17psi, then tapering down to about 12psi at redline. Is this the same boost pattern that other stage II users are seeing?




* Registered users of the site do not see these ads.

Last edited by Jard; 09-20-2004 at 05:06 PM. Reason: title
Jard is offline   Reply With Quote
Old 09-19-2004, 08:27 PM   #2
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

Jard is offline   Reply With Quote
Old 09-19-2004, 08:29 PM   #3
Ironlung
Scooby Newbie
 
Member#: 52121
Join Date: Jan 2004
Location: Centreville
Vehicle:
2004 WRX
WRB

Default

Wow, I've never hit 17psi... i'm at 14 in 2nd and 15.5-16 in 3-5.

Jeff
Ironlung is offline   Reply With Quote
Old 09-19-2004, 08:30 PM   #4
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

Does your boost hold that high the whole way to redline...or does it taper down?
Jard is offline   Reply With Quote
Old 09-19-2004, 11:26 PM   #5
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Cobb's stuff tends to run rich silly rabbit. Richer is better than leaner. Sadly I didn't make it to that dyno day as I was at the Subaru Challenge. I would like to have met you and had a little wagon vs. wagon dyno session. I'm sure I would put down more than 220 though.
Unabomber is offline   Reply With Quote
Old 09-19-2004, 11:58 PM   #6
QKWRX
Scooby Specialist
 
Member#: 66711
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Richland, Wa
Vehicle:
01 BMW 330CIC
LMY

Default

What map version are you running?
QKWRX is offline   Reply With Quote
Old 09-20-2004, 12:23 AM   #7
trustWRX
Scooby Specialist
 
Member#: 40431
Join Date: Jul 2003
Chapter/Region: SCIC
Vehicle:
2009 Scion XB

Default

COBB's own dynos show 224whp on their website so you're running right about what they claim it puts down so that makes me happy as well although I havent dynoed mine yet.

On the boost question mine hits 15.x then climbs up to 16Psi..holds there for a split second then tapers down. So yeah, it sounds about right.

I want to get mine dynoed soon.

Injen Turboback (no cats)
Stock uppipe w/ cat
GFB 50/50 BoV.
trustWRX is offline   Reply With Quote
Old 09-20-2004, 01:06 AM   #8
SonnyCrockett04
Scooby Specialist
 
Member#: 48838
Join Date: Nov 2003
Chapter/Region: BAIC
Location: The Bay
Vehicle:
2008 Stage 2 STI
A.W.

Default

I'm running stage 2 on 91 octane, gutted uppipe, Godspeed downpipe, and a Thermal catback and I can hit 16.5 PSI in 2nd-5th, tapering to 14PSI only in 2nd. I know it sounds crazy but it wasn't always like this. I've gotten it to run like this only after shortening the wastegate actuator arm a few turns.
SonnyCrockett04 is offline   Reply With Quote
Old 09-20-2004, 01:20 AM   #9
trustWRX
Scooby Specialist
 
Member#: 40431
Join Date: Jul 2003
Chapter/Region: SCIC
Vehicle:
2009 Scion XB

Default

Quote:
Originally Posted by SonnyCrockett04
I'm running stage 2 on 91 octane, gutted uppipe, Godspeed downpipe, and a Thermal catback and I can hit 16.5 PSI in 2nd-5th, tapering to 14PSI only in 2nd. I know it sounds crazy but it wasn't always like this. I've gotten it to run like this only after shortening the wastegate actuator arm a few turns.
Dang that would freak me out. I see my EGT's climb to 1300F and it freaks me out. Today I hit 1400F. The thing that freaks me out is the fact that my EGT probe is in my downpipe so the difference in actual temperature is probably around +200F. So maintaining a high Boost like you would probably blow my car up
trustWRX is offline   Reply With Quote
Old 09-20-2004, 01:45 AM   #10
imprzya
Scooby Specialist
 
Member#: 12181
Join Date: Nov 2001
Chapter/Region: MWSOC
Location: Ankeny, Iowa
Vehicle:
2004 STi WRBro
15 Forester Touring

Default

I just ran my car today, cobb stage 2, 93, v 1.20, up, dp, samco ic hoses. Im hitting a max boost of 15.8 in 3rd and 16.7 in 4th tapering off almost immediately. My EGTs also are fine, never over 1500 and my probe is in the right place. I got 12 1/4 mi runs in today, 80degrees, humid. My best time was 13.8 @97
imprzya is offline   Reply With Quote
Old 09-20-2004, 02:01 AM   #11
SonnyCrockett04
Scooby Specialist
 
Member#: 48838
Join Date: Nov 2003
Chapter/Region: BAIC
Location: The Bay
Vehicle:
2008 Stage 2 STI
A.W.

Default

I dunno I think I got a freak car....probably built on a Tuesday, ;D.
SonnyCrockett04 is offline   Reply With Quote
Old 09-20-2004, 02:41 AM   #12
AK*WRX*2004
Scooby Specialist
 
Member#: 56485
Join Date: Mar 2004
Chapter/Region: AKIC
Location: Juneau, Alaska
Vehicle:
2009 Ram 1500 CC SPT
R.I.P. Bro

Default .

Imprezya , isn't that a little low for the Cobb stg. 2??? I was going to go this path but if those are the regular #'s then i might have to reconsider... Thanks for the info. -Gene
AK*WRX*2004 is offline   Reply With Quote
Old 09-20-2004, 08:11 AM   #13
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

I was thinking that I may have to shorten the wastegate actuator arm a little to get it to hold boost to redline, but if it's already doing what it is supposed to, then it's okay. The charts show that I'm not really losing power as it tapers to redline.

I'm running the Stage II 91 Octane v.1.20 map.

I'm surprised I didn't see at least a little gain with the header, but I'm confident it is keeping my EGTs nice and low. I have never seen over 1500 F with the probe in #4 cylinder in the header a few inches down.

Last edited by Jard; 09-20-2004 at 08:28 AM.
Jard is offline   Reply With Quote
Old 09-20-2004, 10:03 AM   #14
TurbojonLS
Scooby Guru
 
Member#: 38772
Join Date: Jun 2003
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2 Cars, No Bling

Default

Jared - Why aren't you running the 93 Octane map? You have figured out that we have 93 Octane in Virginia, haven't you?
TurbojonLS is offline   Reply With Quote
Old 09-20-2004, 10:06 AM   #15
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

Quote:
Originally Posted by TurbojonLS
Jared - Why aren't you running the 93 Octane map? You have figured out that we have 93 Octane in Virginia, haven't you?
I was running the 91 Octane map mostly because I wanted to run the motor as safely as possbile (rich). It's not worth the extra 5hp to me that you get from the 93 Octane map. Also, sometimes I have to use 92 when I am back in PA.
Jard is offline   Reply With Quote
Old 09-20-2004, 11:00 AM   #16
imprzya
Scooby Specialist
 
Member#: 12181
Join Date: Nov 2001
Chapter/Region: MWSOC
Location: Ankeny, Iowa
Vehicle:
2004 STi WRBro
15 Forester Touring

Default

Quote:
Originally Posted by AK*WRX*2004
Imprezya , isn't that a little low for the Cobb stg. 2??? I was going to go this path but if those are the regular #'s then i might have to reconsider... Thanks for the info. -Gene

It was my first time ever racing, and i didnt have a decent run until about my 5th run. By then, my car was so hot that i was losing power. Also, you can compare it to this, and sti with header back exhaust was running a 13.4 and a vishnu stage 2 rex (like cobb stage 2.5) was running a 13.6, so my 13.8 was good for the hot day at the track.
imprzya is offline   Reply With Quote
Old 09-20-2004, 11:29 AM   #17
snvin
Scooby Specialist
 
Member#: 50578
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: -= /\ is awesome.=-
Vehicle:
2009 2.5i. Bleh.
-=Forza Azzurri=-

Default

Quote:
Originally Posted by STiJard
Shouldn't the hood be open w/ a fan blowing on the I/C!?!?!
snvin is offline   Reply With Quote
Old 09-20-2004, 11:32 AM   #18
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

With the hood closed, it's blowing directly into the scoop. There is a much better seal to the IC that way.
Jard is offline   Reply With Quote
Old 09-20-2004, 12:12 PM   #19
rankink
Scooby Specialist
 
Member#: 12901
Join Date: Dec 2001
Chapter/Region: South East
Location: Miami Springs, FL
Vehicle:
2005 STi/95 VX
Pastelito Racing / SFSOC

Default

Quote:
Originally Posted by imprzya
It was my first time ever racing, and i didnt have a decent run until about my 5th run. By then, my car was so hot that i was losing power. Also, you can compare it to this, and sti with header back exhaust was running a 13.4 and a vishnu stage 2 rex (like cobb stage 2.5) was running a 13.6, so my 13.8 was good for the hot day at the track.

Where are you located as well? I know down here in South Florida we will run almost half a second slower due to the heat and humidity.
rankink is offline   Reply With Quote
Old 09-20-2004, 12:44 PM   #20
GRNMTNRS
Scooby Specialist
 
Member#: 7607
Join Date: Jun 2001
Chapter/Region: NESIC
Location: Vermont
Vehicle:
04 forester
red granite

Default

Your boost levels are higher than mine as well. I am hitting no higher than 16.5 in any gear. I am running the 93 stage 2 ver1.20.

I want to see what sort of #'s I am putting down soon, as well.

Go Wagons......
GRNMTNRS is offline   Reply With Quote
Old 09-20-2004, 03:32 PM   #21
imprzya
Scooby Specialist
 
Member#: 12181
Join Date: Nov 2001
Chapter/Region: MWSOC
Location: Ankeny, Iowa
Vehicle:
2004 STi WRBro
15 Forester Touring

Default

Quote:
Originally Posted by rankink
Where are you located as well? I know down here in South Florida we will run almost half a second slower due to the heat and humidity.
I'm in Wisconsin and we are having record heat. Yesterday we set a record at 85 degrees, and WI is alway humid, usually around 80%-90%. Sitting in rex was like sitting in a sauna, well, plus some humidity. SO yeah, i wanna run again when we finally get back to our normal temps of around 60F.
imprzya is offline   Reply With Quote
Old 09-20-2004, 04:31 PM   #22
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

added chart
Jard is offline   Reply With Quote
Old 09-20-2004, 05:04 PM   #23
TurbojonLS
Scooby Guru
 
Member#: 38772
Join Date: Jun 2003
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2 Cars, No Bling

Default

How rich were you running? Did you get the AFR Printout too? I'm guessing no or you would have posted it too...
TurbojonLS is offline   Reply With Quote
Old 09-20-2004, 05:08 PM   #24
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

just added
Jard is offline   Reply With Quote
Old 09-20-2004, 05:43 PM   #25
rankink
Scooby Specialist
 
Member#: 12901
Join Date: Dec 2001
Chapter/Region: South East
Location: Miami Springs, FL
Vehicle:
2005 STi/95 VX
Pastelito Racing / SFSOC

Default

Quote:
Originally Posted by imprzya
I'm in Wisconsin and we are having record heat. Yesterday we set a record at 85 degrees, and WI is alway humid, usually around 80%-90%. Sitting in rex was like sitting in a sauna, well, plus some humidity. SO yeah, i wanna run again when we finally get back to our normal temps of around 60F.
OK, kinda like S. Florida as we are around 85-95 with 90-100% humidity. Waiting another month until I test my stage 2 on the track with better temps and less humidity.
rankink is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just went cobb stage 2, some thoughts and questions. SiC Stoner Factory 2.0L Turbo Powertrain 33 03-24-2006 12:18 AM
My Cobb Stage 1 dyno #'s Drews_WRX Engine Management & Tuning 8 07-26-2004 09:12 PM
Cobb stage 1&2 dyno #'s speedypete Forester Forum 4 06-14-2004 12:26 PM
Cobb Stage 2 Dyno sheet AlanWRX Texas Impreza Club Forum -- TXIC 8 12-12-2003 05:36 PM
TurboXS stage 2 dyno #'s using stock muffler? blkwag Factory 2.0L Turbo Powertrain 43 02-12-2002 07:46 PM


All times are GMT -4. The time now is 04:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.