Welcome to the North American Subaru Impreza Owners Club Wednesday April 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-21-2004, 02:44 PM   #1
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default Hard starts- '98 2.5RS

Ok, well my car has been at the shop getting a new motor for a few months now, and I am close to getting it back. Problem is, The car has really hard starts, but as soon as it comes to temp, it runs fine. The tech said the fuel pressure is at 28-30psi at start up, and a little more at idle. It idles fine, just has hard starts. He said its not the fuel filter, and we put in a RS fuel pump, and a new WRX fuel pump, neither one solved the issue. He is looking into the injectors to see if they are somehow clogged. Does anyone else has any ideas of what may be wrong? I'm starting to second guess the tech's way of reasoning. A local guy mentioned that the impreza may have a cold start injector, is that true? Could that be causing it?

Thanks in advance,
Brian
* Registered users of the site do not see these ads.
rhdude is offline   Reply With Quote
Old 09-21-2004, 08:06 PM   #2
Homemade WRX
Scooby Guru
 
Member#: 33782
Join Date: Mar 2003
Chapter/Region: MAIC
Location: 3MI Racing LLC
Vehicle:
96 bastard child
search FIRST, then PM!!!

Default

so the fuel pressure is low or high? have you checked lines and rails? I take it the injectors are going to be getting cleaned?
Homemade WRX is offline   Reply With Quote
Old 09-21-2004, 08:51 PM   #3
AJ711
Scooby Specialist
 
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
Vehicle:
98 GM67 + 03 SG6
2 whls > 4 whls

Default

Fuel pressures are what I'm seeing during daily driving. I don't think the issue is there.

I'd be guessing more along the lines of the injectors or spark plug wires at the very longest shot. Maybe purchase one of those injector cleaner fuel add in, as I don't think you can take those out and scrub them off with a toothbrush or something (but I may be wrong about that).

Any thoughts on the starter motor as well? What about the electrical system, is that getting the starter enough current to get things moving properly?

I don't know really, just tossing ideas out there.

AJ
AJ711 is online now   Reply With Quote
Old 09-21-2004, 09:55 PM   #4
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

Turns out its an electrical issue in the injector relays, they are'nt functioning as they should. He will be looking into it tomorrow. I may need a new ECU, but I can score one for $150...
rhdude is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
spotted, green '98 2.5RS RidinLow Tri-State Area Forum 35 01-16-2002 05:53 PM
Blondie in '98 2.5RS Sighting... Ovaltine Vancouver Impreza Club Forum -- VIC 4 08-22-2001 09:44 PM
'98 2.5RS For Sale in Tampa! Opie South East Region Forum 1 07-12-2001 09:05 AM
For sale: '98 2.5RS couple FstrMnky Mid West Subaru Owners Club Forum -- MWSOC 1 06-11-2001 12:04 AM
Attn: All '98 2.5RS Owners - Survey Trey General Forum Archive 44 10-12-2000 04:55 PM


All times are GMT -4. The time now is 02:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.