Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-20-2000, 01:30 PM   #1
Saw Jai
Scooby Specialist
 
Member#: 716
Join Date: Jan 2000
Location: Cupertino, CA USA
Vehicle:
MY00 Impreza 2.5RS
Blue Ridge Pearl

Question Messed up Forum?

I can't seem to access the general forum...anyone else having this problem? Eveything else loads up fine...but I just stall when i try to load up the General Forum...
* Registered users of the site do not see these ads.
Saw Jai is offline   Reply With Quote
Old 04-20-2000, 01:34 PM   #2
WRXGirl
Scooby Specialist
 
Member#: 881
Join Date: Feb 2000
Location: Margarita Ville
Vehicle:
2004 WRX
Grey

Post

I am also having problems!
WRXGirl is offline   Reply With Quote
Old 04-21-2000, 08:48 AM   #3
HomerJay
Scooby Specialist
 
Member#: 1135
Join Date: Mar 2000
Chapter/Region: BAIC
Location: BAICED
Vehicle:
2005 WRX WAGON
Silver

Smile

It was down for repairs. Too many hits and posts.
HomerJay is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UP and DP install, car messed up bad!! Lurkin4Life Newbies & FAQs 50 02-17-2008 03:40 AM
Messed up with touch-up paint 04luchini Car Care & Detailing 14 05-28-2007 07:31 PM
How bad did I mess up my WRX (posted in correct forum now) 2003yellowWRX Factory 2.0L Turbo Powertrain 7 02-06-2006 02:31 PM
so i go to LA mess up my brakes and end up on the Fast and the Furious set gokou006 Southern California Impreza Club Forum -- SCIC 4 03-18-2003 07:27 PM
OT: What the heck? my forums are messed up Overtime Technical Forum Archive 20 08-01-2000 07:00 PM


All times are GMT -4. The time now is 02:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.