Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-19-2001, 11:43 PM   #1
Marinator
Scooby Newbie
 
Member#: 7644
Join Date: Jun 2001
Location: Coquitlam, B.C.
Vehicle:
1993 Impreza L
White

Unhappy Cruise control help

Hi, I have a '93 Impreza, auto, and the cruise does not work. Does anyone have any suggestions on where to start testing? The fuse is good and the panel light comes on.

Thanks
* Registered users of the site do not see these ads.
Marinator is offline   Reply With Quote
Old 06-20-2001, 12:39 AM   #2
preza
Scooby Specialist
 
Member#: 1454
Join Date: May 2000
Location: Wyoming
Vehicle:
2000 2.5 RS-T
Blue

Default

Check your vacum lines, that was why mine wasnt working
preza is offline   Reply With Quote
Old 06-20-2001, 12:49 AM   #3
Fish
RIP Sirkbac
 
Member#: 869
Join Date: Feb 2000
Chapter/Region: NESIC
Location: Nashua NH
Vehicle:
1987 GPZ-750 TURBO
90' MX-5/11' DGM STi Sdn

Default

yeah.. the vacume line was the reason mine stopped..

check it.
Fish is offline   Reply With Quote
Old 06-20-2001, 09:00 PM   #4
Silver Sleeper
Scooby Newbie
 
Member#: 7423
Join Date: Jun 2001
Location: Marion, IA USA
Vehicle:
2002 WRX Sport Wagon
Platinum Silver Metallic

Post

Marinator,

Does your horn still work? I know that might be a silly question but when I had my MY98RS, the horn and cruise quit working at the same time.

I took it into the dealer and they had to replace the "clockspring" mechanism in the steering wheel.

Apparently this mechanism contains all of the electrical contacts for the steering wheel. Horn, curise, airbag...

My horn and cruise did work very intermitently, but really hardly at all.

Cost me almost 450 bucks to get the problem diagnosed and fixed!
Silver Sleeper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control help ursine Electrical & Lighting 26 06-03-2004 07:32 PM
Broken Cruise Control, HELP BlueBerryRex Electrical & Lighting 3 03-11-2004 11:54 PM
cruise control help M E R C U R Y Electrical & Lighting 0 10-26-2003 10:50 AM
removing cruise control HELP gr8wheels Factory 2.0L Turbo Powertrain 1 09-22-2002 06:00 PM
Button Blanks by the Cruise Control...Help me out here! wrx182 Interior & Exterior Modification 2 02-14-2002 01:15 PM


All times are GMT -4. The time now is 09:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.