Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-02-2004, 03:40 PM   #1
popnGEAR
Scooby Specialist
 
Member#: 4616
Join Date: Mar 2001
Location: Bellevue, WA
Vehicle:
1999 2.5RS
RBP

Default Major Engine Problem, help!

So I used to have blown headgaskets but I had those replaced with the gaskets with the updated design and things have been fine for the past 5 months. Yesterday however, while i was driving home fumes began emitting from beneath the passenger side of my hood. When I stopped to check, i could see all over the passenger side underneath the hood was coolant everywhere. With my prior blown headgasket issue, the coolant would only spew out from the overflow and end up on the driver side. Now I can't drive for more than a couple minutes and it will beging fuming. Also there is a kind of ticking noise coming from the engine bay. Any ideas what this may be?? It sounds like it's expensive and I think I am just going to trade in my car.

Thanks guys
* Registered users of the site do not see these ads.
popnGEAR is offline   Reply With Quote
Old 10-03-2004, 03:45 AM   #2
Honkey3k
Scooby Specialist
 
Member#: 53992
Join Date: Jan 2004
Chapter/Region: BAIC
Location: Chico, Ca
Vehicle:
SOLD CGM 2005 2.5RS
35 PSI -- in my tires

Default

leaky hose?
Honkey3k is offline   Reply With Quote
Old 10-03-2004, 05:08 AM   #3
RyansJDMgc8
Scooby Newbie
 
Member#: 65462
Join Date: Jul 2004
Location: Riverside CA USA
Vehicle:
01' 2.5RS
Silver/Carbon Fiber

Default

Freeze plug?
RyansJDMgc8 is offline   Reply With Quote
Old 10-03-2004, 12:41 PM   #4
jamesfacts
NASIOC Supporter
 
Member#: 51282
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: Brooklyn NYC
Vehicle:
98 RS
black & blue from parking

Default

Water pump?
jamesfacts is offline   Reply With Quote
Old 10-03-2004, 07:27 PM   #5
ruskiyab
Scooby Newbie
 
Member#: 55128
Join Date: Feb 2004
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
2007 Impreza WRX
OBP

Default

blinker fluid?

in all seriousness, first see where the coolant is coming from, then panic
ruskiyab is offline   Reply With Quote
Old 10-03-2004, 10:54 PM   #6
popnGEAR
Scooby Specialist
 
Member#: 4616
Join Date: Mar 2001
Location: Bellevue, WA
Vehicle:
1999 2.5RS
RBP

Default

well it turns out to be a pinhole in my rad hose, so i'm gonna get that replaced and see if it does the job. thanks for the advice.
popnGEAR is offline   Reply With Quote
Old 10-03-2004, 11:05 PM   #7
dmatthew
Scooby Newbie
 
Member#: 69247
Join Date: Aug 2004
Chapter/Region: E. Canada
Location: Toronto, Ontario - Canada
Vehicle:
2005 2.5 RS Wagon
Crystal Gray Metallic

Default

lol blinker fluid
dmatthew is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Engine Problem TheShadowWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 07-26-2006 10:14 AM
Major Idle problem ? Help ? galacticWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 08-18-2005 02:12 PM
Major Engine Problem, help! popnGEAR Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 0 10-02-2004 03:38 PM
Major Engine Problem!!! mattjk Southern California Impreza Club Forum -- SCIC 38 10-04-2003 08:32 PM
Major Engine Problems! SubaruImpreza_power Newbies & FAQs 4 09-05-2003 04:09 PM


All times are GMT -4. The time now is 05:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.