Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-07-2004, 12:12 PM   #1
stevenh
Scooby Newbie
 
Member#: 35277
Join Date: Apr 2003
Location: Dallas Tx
Default Anyone have an old broken 02 sensor laying around?

Hey, I've been having some trouble keeping the wideband plug in my downpipe. I lost it for my second time today and can't drive my car without it because the exhaust gasses shoot straight on to some wires which don't look like they are taking the heat too well. I was thinking of using an old 02 sensor to plug it up and think it will work better since I could really crank down on one of those unlike my last plug which simply falls into the downpipe if I tighten it to much. Any help would be GREATLY appreciated and I'd be willing to pay for one if you wanted some cash for it. I may have to drive to the airport today and I'd like to avoid paying 50 bucks for a cab if possible. Thanks for the help.

EDIT: In the dallas area btw
* Registered users of the site do not see these ads.

Last edited by stevenh; 10-07-2004 at 12:22 PM.
stevenh is offline   Reply With Quote
Old 10-07-2004, 01:21 PM   #2
junnel20
Scooby Specialist
 
Member#: 39575
Join Date: Jul 2003
Chapter/Region: TXIC
Location: Beaumont, TX
Vehicle:
2005 WRX STi
WR Blue

Default

Is the o2 sensor plug the same as the sensor on the uppipe from an '03wrx? If so, don't pay the 50bucks for a cab, you can pay me and i'll sell you my uppipe with the o2 sensor plug in it.
junnel20 is offline   Reply With Quote
Old 10-07-2004, 01:50 PM   #3
stevenh
Scooby Newbie
 
Member#: 35277
Join Date: Apr 2003
Location: Dallas Tx
Default

No need for an up-pipe, just looking for an 02 sensor or plug for one.
stevenh is offline   Reply With Quote
Old 10-07-2004, 02:27 PM   #4
Sam2
Scooby Specialist
 
Member#: 15265
Join Date: Feb 2002
Location: Austin Texas
Vehicle:
2002 WRX Wagon
WR Blue

Default

Why not just use a short bolt?
Pretty sure it's M18 w/ 1.50 mm thread.
Anti-sieze the threads . Use star or lock washer.
Don't torque the crap out of it or you'll strip threads.
Sam2 is offline   Reply With Quote
Old 10-07-2004, 02:33 PM   #5
stevenh
Scooby Newbie
 
Member#: 35277
Join Date: Apr 2003
Location: Dallas Tx
Default

I had no luck finding a bolt my fist time around. I tried home depot, pep boys and discount auto parts with no luck. I ended up having to go out to wasabi to get a plug but I don't have a car I can drive out there and I'm not gonna put 30 miles on my car with an exhaust leak like that.
stevenh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anyone have an old tire laying around? tabrad RMIC Private Classifieds 6 08-26-2008 12:36 AM
werid nnj request - anyone have an extra DVI-CRT adapter laying around? Tensen Tri-State Area Forum 10 03-17-2006 12:03 PM
Anyone Have An Old i-Mac Laying Around..? N'CTRL Tri-State Area Forum 4 11-19-2004 09:45 AM
anyone have any old boxed genesis games laying around they don't want? RaceCarRiot Off-Topic 4 10-22-2004 05:12 PM
Anyone have an old broken or otherwise coil they give me for cheap? ciper Legacy Forum 4 07-17-2002 04:51 PM


All times are GMT -4. The time now is 03:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.