Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-07-2004, 07:11 PM   #1
CatchMyDrift
Scooby Specialist
 
Member#: 54523
Join Date: Feb 2004
Chapter/Region: BAIC
Location: Chico,CA
Exclamation EJ25 Need help PLEASE!

Honkey3k and I just finished our first motor swap. Well, we replaced his shortblock. He has a 98 Legacy Outback with an EJ25D motor. We replaced the shortlbock with one from a 2000 Legacy. Supposedly the motors were the same. Come to find out the pistons were different. His stock pistons seamed to be lower compression pistons than the ones in the newer block. The older ones looked almost identical to the WRX pistons. The new ones have little ridges instead of the square cut.

So we have everything wired up correctly ( To the best of our knowledge ), all the hoses connected and vacuum lines connected. Coolent is in, oil is in, spark plugs in and gaped correctly. (Everything) But when we try to start it, there doesn't seam to be any compression. The starter engages nicely, plenty of fuel, plenty of spark. But there's smoke coming out of the intake.

So we unhooked the intake from the throttle body thinking thats where it was coming from. Nope. It was coming from the largest hose that connects from the intake manifold to the intake itself. ( The long black tube ) It's no ordinary smoke though. There's a gas smell to it when it blasts out, but when I wipe it the smell is gone. Could it be water?

Justin and I will have a short video clip up in a bit to give you a better idea. Anybody with comments are welcome.

Thanks for your help,
Benny
* Registered users of the site do not see these ads.
CatchMyDrift is offline   Reply With Quote
Old 10-07-2004, 08:48 PM   #2
Honkey3k
Scooby Specialist
 
Member#: 53992
Join Date: Jan 2004
Chapter/Region: BAIC
Location: Chico, Ca
Vehicle:
SOLD CGM 2005 2.5RS
35 PSI -- in my tires

Default

Ok, we had some other guys stop by and take a look. Their best guess is that the timing is off. Justin had a family friend put his motor together, along with a new timing belt. Were still working on it.

Benny
Honkey3k is offline   Reply With Quote
Old 10-07-2004, 10:24 PM   #3
Honkey3k
Scooby Specialist
 
Member#: 53992
Join Date: Jan 2004
Chapter/Region: BAIC
Location: Chico, Ca
Vehicle:
SOLD CGM 2005 2.5RS
35 PSI -- in my tires

Default

*Update*

We found the prob. The timing was off by 180 degrees. Our exhaust was trying to come out the intake. Im a post whore too. What can I say.

Mods...This thread is done.
Honkey3k is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NNJ: Need to use a lift or need help! PLEASE! CoBB_tHiS! Tri-State Area Forum 6 05-05-2010 06:46 PM
i need help.. PLEASE HELP. WRXdriver04 Engine Management & Tuning 6 12-14-2005 10:17 AM
need help, please help!!! ralyrcr Mid West Subaru Owners Club Forum -- MWSOC 11 08-30-2005 09:39 PM
I need to order a clutch ASAP - Need help please Rizzo314 Transmission (AT/MT) & Driveline 3 11-05-2004 08:10 AM
Hard Drive Recover Help much needed... ATA RAID 0 knowledge needed HELP PLEASE!!! 2k2 Off-Topic 63 12-24-2003 11:35 PM


All times are GMT -4. The time now is 02:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.