Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-25-2004, 08:00 PM   #1
markk26
Scooby Newbie
 
Member#: 54698
Join Date: Feb 2004
Location: Montreal , Quebec , Canada
Vehicle:
1997 Legacy GT
red

Default 2.5 idle problem

Ok , here it is...
The idle on my 97 Legacy GT 2.5 DOHC (125 000 KM) stays at about 1800 rpms.
Out of the blue , no idea what it can be.
Yesterday i changed my oil like i did a hundred time , took a little run around the block , everything was peachy.
Today , take my car to go the store , out of the blue , idle wont get down from 1800 rpms.
Nothing happend , no idea.
The only thing is that i changed from synthetic oil 10w30 to normal Valvoline oil 10w30 , used the exact same brand and model of oil filter.
I noticed that my engine "knock" is getting louder , that's why i'm looking into completly changing it.
Anyone has an idea what it could be?
* Registered users of the site do not see these ads.
markk26 is offline   Reply With Quote
Old 10-25-2004, 08:52 PM   #2
Caplin 2.5
Scooby Specialist
 
Member#: 71203
Join Date: Sep 2004
Location: SoCaL
Vehicle:
2005 2.5rs
Crystal Gray Metallic

Default

When you get in your car, give it a few good revs before you get goin, it should drop down below to 1000 w/ ac on and maybe lower without ac on. but if it doesn't drop then i don't know.
Caplin 2.5 is offline   Reply With Quote
Old 10-25-2004, 09:29 PM   #3
markk26
Scooby Newbie
 
Member#: 54698
Join Date: Feb 2004
Location: Montreal , Quebec , Canada
Vehicle:
1997 Legacy GT
red

Default

It's close to freezing point now here in Montreal ! , no need for a/c !..
And this problem is not at a cold start , it is when i have been driving for a long time and the engine is at running temp.

Still no clue.
markk26 is offline   Reply With Quote
Old 10-25-2004, 09:32 PM   #4
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

idle air control valve could be sticking open a bit. Unfortunatly its a very expesnsive part to guess at.

Jay
munkis is offline   Reply With Quote
Old 10-25-2004, 09:58 PM   #5
ImprezaVA
Scooby Specialist
 
Member#: 32846
Join Date: Feb 2003
Chapter/Region: MAIC
Location: Elkton, VA
Vehicle:
1998 Impreza L-SOLD
Arcadia Green

Post IAC Valve

Try cleaning your IAC valve with alcohol or throttle body cleaner. I've used both recently on my mother's car. It fixed the problem for a week, and then the surging came back again. On the 3rd try, I used WD-40, which is a good cleaner and decent, at best, lubricator. Problem fixed.

-Charles-
ImprezaVA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.0-2.5 swap problems, STARTER & FUEL INJECTOR STUCK ON??? aarongivey Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 07-31-2010 03:16 AM
Help on a 2.5 idle issue Morningriders Legacy Forum 2 12-02-2004 10:09 AM
2.5 Backfire problem Cooljo2.5rs Normally Aspirated Powertrain 10 04-29-2004 07:02 PM
99 2.5 idle prob garret Normally Aspirated Powertrain 0 09-17-2003 10:17 PM
'04 STI 2.5 motor problems??? alfriedesq STi Forum Archive 5 01-19-2003 03:18 AM


All times are GMT -4. The time now is 05:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.