Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2004, 07:46 PM   #1
sniece
Scooby Newbie
 
Member#: 9935
Join Date: Sep 2001
Chapter/Region: E. Canada
Location: Hamilton, Ontario, Canada
Vehicle:
2002 WRX
WRB

Default Oil in Coolant

OK, so I've just barely crossed over the 100,000km warranty point (by 600km) with my 2002 WRX, which I recently purchased used. When I got it, at about 95K km, everything looked hunky dory. Recently, there's a ring of oil appearing in the rad overflow tank.

I'm going into the dealer with it regardless of it being covered by warranty or not, it's got to be better to deal with it now, rather than later. Has anyone run into a similar problem? From what I was told (dealer that serviced the car) all maintenance was done like clockwork, and there weren't any major repairs, so I'm assuming there wasn't anything stupid like the coolant running low and the heads warping. There isn't a lot of oil in there after about 3500km since the coolant was changed at the 96K km service, and the coolant level looks fine, so I'm guessing it's not burning coolant. (it's a little high if anything)

Anyway, just looking for any similar situations folks have been in so I can try and talk to the dealer knowledgably about it.

Thanks,
Stephen
* Registered users of the site do not see these ads.
sniece is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil in Coolant Question Astralogical Service & Maintenance 0 10-09-2006 01:18 PM
bad radiator. oil in coolant. what to do!?! koyo users.. jfizzle024 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 06-15-2006 09:27 AM
Oil in Coolant STISTL Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 08-04-2005 07:59 PM
2005 WRB WRX, think theres oil in coolant onyx445 Newbies & FAQs 8 05-30-2005 07:51 PM
Sources of Oil in Coolant? Impreza Rider Mid Atlantic Impreza Club -- MAIC 15 08-29-2003 04:36 PM


All times are GMT -4. The time now is 04:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.