Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-14-2004, 07:39 PM   #1
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Angry DCCD Failure on 05 sti

ok i picked up my 05 sti last night after i traded in my 04 wrx...on the drive home car cutt off twice!!!! every time it does it my dccd goes to that green square ( manual mode i am guessing) ... then i could just take the key out and put it back in and it would work fine.... well now it takes a few tries before i can do it. car has 200 miles on it, and the ride home was about 160... i got the car with 2 miles on it. Dealership is sending a flat bed with a loaner tomorrow, but i want my sti now....any ides what it might be, or any suggestions on what should i do... i told the dealeship that if they have to change any parts that i want another one. please help
* Registered users of the site do not see these ads.
z_wrecker is offline   Reply With Quote
Old 11-14-2004, 07:45 PM   #2
05 Subaru-STi
*** Banned ***
 
Member#: 72837
Join Date: Oct 2004
Location: Urbana IL.
Vehicle:
2005 STi
wr blue

Default

it seems to me that alot of probs that shoudlnt happen like that are happening, i had some bs too and i have alot less faith in subaru nowa days.
05 Subaru-STi is offline   Reply With Quote
Old 11-14-2004, 07:54 PM   #3
STi-MAN
Scooby Guru
 
Member#: 70252
Join Date: Sep 2004
Vehicle:
05 STI
blue

Default

never had this problem ur talking about have a 05 too.
STi-MAN is offline   Reply With Quote
Old 11-14-2004, 08:36 PM   #4
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Default

i am not saying its a common problem.... i am just saying it happened on that car. other than that its a super sweet ride
z_wrecker is offline   Reply With Quote
Old 11-14-2004, 09:55 PM   #5
949
Scooby Specialist
 
Member#: 58906
Join Date: Apr 2004
Default

tell us what the problem the dealer said later and what the solution is too. very curious here.
949 is offline   Reply With Quote
Old 11-14-2004, 10:01 PM   #6
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Default

will do... So far the dealer has been great... i told them that i didn't trust my local dealership, and he is gonna send a flat bed with a loaner car on it first thing tomorrow morning, and my sales guy is actually coming down himself. 140 miles! I just want my beautiful sti back
z_wrecker is offline   Reply With Quote
Old 11-14-2004, 10:13 PM   #7
Notch
Scooby Newbie
 
Member#: 73694
Join Date: Nov 2004
Location: Northern NJ
Vehicle:
2005 WRX STI
CGM

Default

Could be a bad ground somewhere or wires not hooked up correctly or worked their way loose.. My DCCD would not go out of auto mode and it was two wires underneath the car not hooked up all the way. Electrical problems are the hardest to track down.
Notch is offline   Reply With Quote
Old 11-14-2004, 10:25 PM   #8
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
'08 BMW 135i
F/A-18C

Default

I wouldn't worry about it too much

things like this happen, and it sounds like you're being taken care of
Thumper23 is offline   Reply With Quote
Old 11-14-2004, 10:30 PM   #9
dowroa
Scooby Specialist
 
Member#: 17498
Join Date: Apr 2002
Chapter/Region: South East
Location: Durham, NC
Vehicle:
No More Subarus :(
Only a truck, for now. ;)

Default

all bow down to nhluhr, obviously he knows all.

- dow

Last edited by dowroa; 11-16-2004 at 03:18 PM.
dowroa is offline   Reply With Quote
Old 11-14-2004, 10:54 PM   #10
Nightrunner
Scooby Specialist
 
Member#: 69667
Join Date: Sep 2004
Location: Lost in Memories...
Vehicle:
JGTC Cusco' STi WR1
Contemporary Hair Design

Default

It's funny the dealer never tell us how to use the DCCD when we purchased the car.
Nightrunner is offline   Reply With Quote
Old 11-15-2004, 12:59 AM   #11
05 Subaru-STi
*** Banned ***
 
Member#: 72837
Join Date: Oct 2004
Location: Urbana IL.
Vehicle:
2005 STi
wr blue

Default

yeah cuz for one they cant even tell u what it dose hardly and second its just useless to have a manual mode
05 Subaru-STi is offline   Reply With Quote
Old 11-15-2004, 01:11 AM   #12
NaVaWRX
Scooby Newbie
 
Member#: 48381
Join Date: Nov 2003
Default

well dealer never tell use how it really works and blah blah, but just that b4 i know how to play with the DCCD thing, i wouldn't want to mess with it, my 05 it's got 600miles right now and still working fine, no problem at all yet.... so i'm guess it's just something about the DCCD.

so r u saying that u change it to MT mode while u are driving or something? don't really get it @@
NaVaWRX is offline   Reply With Quote
Old 11-15-2004, 01:14 AM   #13
ANZAC_1915
Moderator
 
Member#: 456
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Redmond, WA, USA
Vehicle:
2008 Forester XT
Steel Gray Metallic

Default

Quote:
Originally Posted by NaVaWRX
well dealer never tell use how it really works and blah blah, but just that b4 i know how to play with the DCCD thing, i wouldn't want to mess with it, my 05 it's got 600miles right now and still working fine, no problem at all yet.... so i'm guess it's just something about the DCCD.

so r u saying that u change it to MT mode while u are driving or something? don't really get it @@
Most likely it isn't the DCCD itself. There are a few conditions that will cause it to go to safe (open) mode, e.g. rear diff overtemp, etc. They're in the service manual.

For more on the DCCD: http://www.sti-buki.com/forums/showt...php?threadid=6

Glenn
ANZAC_1915 is offline   Reply With Quote
Old 11-15-2004, 07:00 AM   #14
SubEd
Scooby Guru
 
Member#: 717
Join Date: Jan 2000
Chapter/Region: NESIC
Default

Do they still teach English in school these days?
SubEd is offline   Reply With Quote
Old 11-15-2004, 07:01 AM   #15
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Chapter/Region: MWSOC
Location: Rolling Meadows, IL
Vehicle:
'07 TL-S 6MT
'07 RDX-T

Default

<- wants to bang my head against a wall after reading this thread.
happasaiyan is online now   Reply With Quote
Old 11-15-2004, 08:13 AM   #16
attitude
Scooby Specialist
 
Member#: 52043
Join Date: Jan 2004
Chapter/Region: MAIC
Location: Huntington WV
Vehicle:
04 sti

Default

so, does that guy not know what the dccd does? or he didn't now he did? or the dealer grapped on his t3h manual mode? (not you z wrecker )
attitude is offline   Reply With Quote
Old 11-15-2004, 08:15 AM   #17
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

That would be the difference between a Fuji heavy industries STI and a General Motors STI.
What did you expect from Chevy?
Davenow is offline   Reply With Quote
Old 11-15-2004, 08:17 AM   #18
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

BTW this shouldnt be happening due to leaving the diff in manual mode. I know a few STI guys that ALWAYS leave it in manual mode, rolled full rear, and they dont have this problem.
Davenow is offline   Reply With Quote
Old 11-15-2004, 09:33 AM   #19
attitude
Scooby Specialist
 
Member#: 52043
Join Date: Jan 2004
Chapter/Region: MAIC
Location: Huntington WV
Vehicle:
04 sti

Default

me included
attitude is offline   Reply With Quote
Old 11-15-2004, 11:43 AM   #20
engineerx
Scooby Specialist
 
Member#: 42614
Join Date: Sep 2003
Chapter/Region: SCIC
Location: Bullet-Dodging Fwy Los Angeles
Vehicle:
0405 WRX STi/S2000
AspenWhite/Silverstone

Default

11000 miles on my STi,
including a couple of track events (one temperature was near 100F !!)
and no problems to report so far....I always leave it on Auto
Could be one of those one in 1000 cases - tough for you that's 1 in 1000 too many !
Really an inconvenience and suxz since it's your bran new car.... as long as Subaru takes care of it the proper way and it's not a recurring problem!

Keep in mind you can use the lemon law too : they have 3 tries to fix your car and if they don't you can get a refund!

but that's in an extreme case and I think they can fix the DCCD.... however you don't wanna end up w/ a lemon
engineerx is offline   Reply With Quote
Old 11-15-2004, 11:43 AM   #21
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Default

i left mine in auto... i know you are not supposed to change it while driving and such... I am just saying it switches itself to manual and shuts off. they got one of the sti techs to take a look at it tomorrow, so i'll keep you guys updated. and dowroa it's not a user error. I can't even turn the car on most of the time... it keeps turning over.
z_wrecker is offline   Reply With Quote
Old 11-15-2004, 11:46 AM   #22
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Default

i told the dealership if anything needs to be replaced that i want another STI, and they said thats fine. They are a great dealeship. Beyer subaru in Alexandria Virginia...My sales guy is Peter and he is personally driving som 140 miles today to pick up my car and to bring me a loaner vehicle
z_wrecker is offline   Reply With Quote
Old 11-15-2004, 11:54 AM   #23
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Chapter/Region: MWSOC
Location: Rolling Meadows, IL
Vehicle:
'07 TL-S 6MT
'07 RDX-T

Default

Quote:
Originally Posted by z_wrecker
i left mine in auto... i know you are not supposed to change it while driving and such... I am just saying it switches itself to manual and shuts off. they got one of the sti techs to take a look at it tomorrow, so i'll keep you guys updated. and dowroa it's not a user error. I can't even turn the car on most of the time... it keeps turning over.
you can change it while driving. who said you cant?

i dont even know how its possible for the dccd switch to change itself...

...let alone have enough control to shut the car off.

weird one youve got on your hands.
happasaiyan is online now   Reply With Quote
Old 11-15-2004, 12:03 PM   #24
z_wrecker
Scooby Specialist
 
Member#: 65922
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
05 STI
Platinum Silver

Default

thats the thing...the car cutts off on its own... i thought you can't change while in gear...you have to be in neutral....thats what i was told
z_wrecker is offline   Reply With Quote
Old 11-15-2004, 12:48 PM   #25
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Chapter/Region: MWSOC
Location: Rolling Meadows, IL
Vehicle:
'07 TL-S 6MT
'07 RDX-T

Default

i think every time ive adjusted my dccd, the car has been moving. i havent had any problems with it in my 20k miles with the car.
happasaiyan is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
bugeye diffuser on 05 sti?? oly kenji Interior & Exterior Modification 9 06-14-2010 07:51 PM
Reset DCCD on 05 STi?? KiggerSTI Transmission (AT/MT) & Driveline 7 03-05-2010 01:09 PM
Clockspring and DCCD on 05 STi i_drank_what Interior & Exterior Modification 1 10-22-2009 06:06 PM
Cruise Control Failures on 04 STi? MorallyBass Engine Management & Tuning 6 03-12-2007 09:33 AM
dccd issues on 05 sti slowstangguy Newbies & FAQs 1 12-23-2004 04:03 PM


All times are GMT -4. The time now is 02:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.