Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-10-2004, 02:58 AM   #1
STUDAndring
Scooby Newbie
 
Member#: 61891
Join Date: May 2004
Location: Kennewick, WA
Vehicle:
04 WRX
Pearl Blue

Question Throwing CEL after install of Utec stage 4

I am running a utec stage 4 and I have the check engine light on. I got a code reader and it says it is due to the catylitic system so I guess that means that because I have the cat in the uppipe and the cat is the downpipe gone that the highflow cat in the mid pipe is not enough to keep from throwing the CEL. How can I fix this CEL I do not want to just disable the CEL light in the car but I would like to get the car to think that the admissions are fine. Any thing I can do?

Thanks
* Registered users of the site do not see these ads.
STUDAndring is offline   Reply With Quote
Old 12-10-2004, 03:25 AM   #2
faylix
Scooby Newbie
 
Member#: 70184
Join Date: Sep 2004
Chapter/Region: NESIC
Location: Boston
Vehicle:
2012 WRX STI
WRB

Default

Dosn't the UTEC give you the power to surpress these CELs?

or get a CEL fix. Search it.

-J
faylix is offline   Reply With Quote
Old 12-10-2004, 04:31 AM   #3
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

....you have a catted UP with a stage 4????

You REALLY gotta get your ish figured out or you gonna blow it up, quick like.

This particular post is a prime example of doing and NOT knowing....
Uncle Scotty is offline   Reply With Quote
Old 12-10-2004, 05:22 AM   #4
hernan
Scooby Newbie
 
Member#: 51477
Join Date: Dec 2003
Default

Quote:
Originally Posted by Uncle Scotty
....you have a catted UP with a stage 4????

You REALLY gotta get your ish figured out or you gonna blow it up, quick like.

This particular post is a prime example of doing and NOT knowing....
Please, read before posting.
He has no cats, new stage 4 setup and wondering how to get that cel out.
When you don't know something, asking the right question is an excelent first step.
hernan is offline   Reply With Quote
Old 12-10-2004, 06:19 AM   #5
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by hernan
Please, read before posting.
He has no cats, new stage 4 setup and wondering how to get that cel out.
When you don't know something, asking the right question is an excelent first step.

Quote:
...so I guess that means that because I have the cat in the uppipe and the cat is the downpipe gone that the highflow cat in the mid pipe is not enough...
W T F is the above supposed to mean then????

I did read the post, but english being my first language isn't enough these days, I guess...
Uncle Scotty is offline   Reply With Quote
Old 12-10-2004, 10:38 AM   #6
mbiker97
Scooby Guru
 
Member#: 7922
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: Tucson
Vehicle:
04 CTS-V b/b/b
99 GMC Highrider

Default

What is the exact code?

It's probably p0420 (rear O2 inefficiency). Either turn off the CELs in the Utec or do the mechanical fix.

Only do the fix once you know the exact code the ECU is throwing. Don't trust universal code readers on the verbage.
mbiker97 is offline   Reply With Quote
Old 12-10-2004, 10:58 AM   #7
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Quote:
Originally Posted by hernan
Please, read before posting.
He has no cats, new stage 4 setup and wondering how to get that cel out.
When you don't know something, asking the right question is an excelent first step.
Why dont YOU read before posting, he VERY clearly states that he has a high flow cat in the midpipe, which is 1 cat
ANd he VERY clearly states that he has the cat in the up pipe.

Thats 2 cats, 2 counts of you being an idiot.
You need to learn who NOT to say things like that too. Because in general, if you read something they wrote and think its stupid, its YOU that arent understanding what they wrote. There is a reason that these people are generally known as the ones to go to for these questions.



Now, to the original poster. From what you typed it looks like you have an up pipe cat in there. You are NOT at stage 4 with that cat in there, and your car will never run properly with that setup with that cat in there. Please clarify whether or not you do in fact have a catless up pipe, and if you dont, GET IT DONE.

Last edited by Davenow; 12-10-2004 at 11:26 AM.
Davenow is offline   Reply With Quote
Old 12-10-2004, 04:47 PM   #8
zaxrex
Scooby Specialist
 
Member#: 9898
Join Date: Sep 2001
Chapter/Region: MAIC
Location: VA near MD
Vehicle:
2002 WRX
Water Injected Blue

Default

Quote:
Originally Posted by STUDAndring
I have the cat in the uppipe and the cat is the downpipe gone that the highflow cat in the mid pipe is not enough to keep from throwing the CEL.
If my engrish reading is correct, and you were writing in engrish...
Step One:
GET THE UPPIPE CAT OUT.

Step Two:
DO NOT DISABLE CEL WITH UTEC. Whe you turn it off, you won't see when your car is screaming, "for the love of God, STOP".

Step Three:
confirm the CEL codes. Make sure that it is for the rear O2 sensor. This can be fixed by, 1) searching, 2)A-soldering in a MIL eliminator or, B-doing the mechanical CEL fix with spark plug anti-foulers.

There is so much good info here that I cry sometimes...
There is also a shload of poopey that sometimes masks all the goodness....
zaxrex is offline   Reply With Quote
Old 12-13-2004, 02:02 AM   #9
STUDAndring
Scooby Newbie
 
Member#: 61891
Join Date: May 2004
Location: Kennewick, WA
Vehicle:
04 WRX
Pearl Blue

Default

I do not have a cat in the uppipe only the highflow cat in the mid pipe. And I do not want to disable CEL because then if somthing else goes wrong I will never know.
STUDAndring is offline   Reply With Quote
Old 12-13-2004, 10:10 AM   #10
mbiker97
Scooby Guru
 
Member#: 7922
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: Tucson
Vehicle:
04 CTS-V b/b/b
99 GMC Highrider

Default

IIRC when you turn the CEL off with the Utec if a new code pops up it flashes the CEL to alert you of a code.

What is the exact code your car threw?
mbiker97 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bouncing of RPMs after instalation of AP stage 2 20SUBIEWRX02 AccessPort 1 04-14-2008 08:50 PM
Cel After Install Utec gaby UTEC 1 03-03-2006 05:31 PM
best place for Turbo XS UTEC Stage 4 install SoCalWRXwagon Southern California Impreza Club Forum -- SCIC 6 06-30-2004 03:19 PM
anyone have a UTEC stage 4 map with ION instead of a VF30 frdawg Engine Management & Tuning 0 04-14-2003 09:55 PM
utec stage 4 map and stage 4 tmi map the same? datdudedennis Engine Management & Tuning 4 03-18-2003 11:37 PM


All times are GMT -4. The time now is 06:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.