Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-03-2001, 06:50 PM   #1
IMPREZAmike
Scooby Newbie
 
Member#: 169
Join Date: Aug 1999
Location: Warwick and smAlbany NY
Vehicle:
98 black OBS
move bi*ch get out da way

Default i think my timing is off...how do i fix it?

Since i had my timing belt replaced, i have noticed a subtle lag while acelerating, and i think that the timing is off. As i press on the pedal, i get very short 'gaps' (for lack of better word) in the acceleration. no sound is associated with this, but i can feal it. If it is in fact the timing, is this something i can fix, or do i have to have my dealer deal with it?

thanks,
mike
* Registered users of the site do not see these ads.
IMPREZAmike is offline   Reply With Quote
Old 07-04-2001, 12:39 AM   #2
gavin
Scooby Specialist
 
Member#: 3198
Join Date: Dec 2000
Location: Portland, OR USA
Vehicle:
2005 GT LTD Wagon
Garnet Red

Default

Has your mileage gone to hell, too? It's possible that the dealer misaligned a cam when they replaced the timing belt. I'd take it back and have them check it.
gavin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Aftermarket Seats, airbag light is on, how do i fix it? 1FSTREX Interior & Exterior Modification 15 07-06-2011 04:35 PM
The Welfare system is broken. How do we fix it? MrBlue Political Playground 181 02-08-2010 07:10 PM
What is this, how did I break it, and how do I fix it? XanRules Transmission (AT/MT) & Driveline 12 08-20-2009 09:53 AM
HELP! What is this? How did it happen? How do I fix it? MyFirstDeuce Transmission (AT/MT) & Driveline 5 09-24-2006 11:50 PM
Found my probelm- how do I fix it? Oo DaRk StAr oO Electrical & Lighting 7 05-22-2003 02:55 AM


All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.