Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-13-2004, 02:09 PM   #1
Matty
Scooby Specialist
 
Member#: 13408
Join Date: Dec 2001
Location: Hood River ..Oregon
Vehicle:
2008 LGT
black

Default Morretes suddenly dim

Not sure if it's a wiring prob, or some kind of film inhibiting the beam..but they used to be really bright..truckers would flash high beams at me on the freeway...Now I can barely see 50 feet ahead of me...switched to PIAA's and no difference. Anyone else have this problem ??
* Registered users of the site do not see these ads.
Matty is offline   Reply With Quote
Old 12-13-2004, 02:11 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Both sides or just one? Low beams and/or highs? Did you wire them yourself or did they come with plug-in harness adapters?
Mulder is offline   Reply With Quote
Old 12-13-2004, 04:53 PM   #3
Matty
Scooby Specialist
 
Member#: 13408
Join Date: Dec 2001
Location: Hood River ..Oregon
Vehicle:
2008 LGT
black

Default Morrettes

Both sides..I've checked the "aim" ..I did wiring myself, and I also had issues with corrossion (sp) have since soldered the wires but I still egt an occational loose wire. The high beams are fine..just have a problem with low beams..it almost looks like I might have condensation on the inside of the lens..hard to tell though
Matty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Load Suddenly Down, Knock Suddenly Up. Why? williaty Open Source Reflashes 26 10-11-2008 10:41 PM
did anyone's auto dimming mirror suddenly become not auto dimming anymore? SQC120 Interior & Exterior Modification 9 10-08-2007 02:51 PM
Morretes in!!!! HIHO Legacy Forum 90 01-21-2003 05:44 PM
My GT with new Morrets and Hella FF100. HIHO Member's Car Gallery 4 01-20-2002 05:50 PM
If you have Morretes (or getting some) check this out! HIHO Legacy Forum 11 01-12-2002 04:57 PM


All times are GMT -4. The time now is 09:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.