Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-26-2004, 03:06 AM   #1
WRX98Outback
Scooby Newbie
 
Member#: 78172
Join Date: Dec 2004
Location: Corvallis, OR
Vehicle:
98 WRX Outback
Black

Default Misfire problems

I have an '02 WRX in my 98 Outback sport and it have 47k miles and the CEL has been on since i bought it from the previous owner. Everytime i get it checked it says their is a misfire in all 4 cylinder and ive tried doin the plugs and nothing changed. I was going to do coils but i want to know if that is really it, because it doesnt have a big affect in power, and it still pulls great. Also every once in awhile it will flash at me while im cruising around. If it helps i have an intake, full exhaust, new fuel pump, and STi unprung clutch as my only mods. Any help would be awsome Thanks.
* Registered users of the site do not see these ads.
WRX98Outback is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire problems fellfrosch7 Service & Maintenance 7 04-26-2005 05:03 PM
Misfiring problem please help Pochebum Factory 2.0L Turbo Powertrain 13 05-12-2004 03:54 PM
misfiring problems shortfuseWRX Factory 2.0L Turbo Powertrain 7 02-19-2004 08:11 PM
misfiring problem weaversm Service & Maintenance 2 12-17-2001 10:06 PM
My misfire problem.... solved! 8Complex Mid West Subaru Owners Club Forum -- MWSOC 15 07-16-2001 04:07 AM


All times are GMT -4. The time now is 10:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.