Welcome to the North American Subaru Impreza Owners Club Tuesday September 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-26-2004, 10:29 PM   #1
MtnMedic
Scooby Newbie
 
Member#: 28845
Join Date: Nov 2002
Location: North County
Vehicle:
2011 WRX limited 5d
Pearl white

Default Do I need more turbo fluid?

I was driving some hills today. On the up hill side of the first few my CEL started blinking then stopped. Then finally on a steep hill it blinked then stayed on, now it won't go off. No overheating no loss of power. I'm thinking its a fluid level somewhere, but can't check right now cause there is a blizzard outside. Assuming all the levels are ok, you think its ok to drive about 100 miles til i can have it looked at?
* Registered users of the site do not see these ads.
MtnMedic is offline   Reply With Quote
Old 12-26-2004, 10:35 PM   #2
railguy
Scooby Specialist
 
Member#: 53756
Join Date: Jan 2004
Chapter/Region: MAIC
Location: MAIC
Vehicle:
2002 WRX
WRB

Default

turbo fluid??????? oh boy.............
railguy is offline   Reply With Quote
Old 12-26-2004, 10:37 PM   #3
MtnMedic
Scooby Newbie
 
Member#: 28845
Join Date: Nov 2002
Location: North County
Vehicle:
2011 WRX limited 5d
Pearl white

Default

it was a joke
MtnMedic is offline   Reply With Quote
Old 12-26-2004, 10:39 PM   #4
railguy
Scooby Specialist
 
Member#: 53756
Join Date: Jan 2004
Chapter/Region: MAIC
Location: MAIC
Vehicle:
2002 WRX
WRB

Default

Well then good one...............=)
railguy is offline   Reply With Quote
Old 12-26-2004, 10:49 PM   #5
majmun
Scooby Specialist
 
Member#: 18298
Join Date: May 2002
Chapter/Region: SWIC
Vehicle:
2004 STi

Default

Have Kragen/Checker/Autozone pull the code. It's free.



(check your gas cap)
majmun is offline   Reply With Quote
Old 12-26-2004, 10:53 PM   #6
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Check your muffler bearings and your carburator belts.(had to do it)
quazimoto is offline   Reply With Quote
Old 12-26-2004, 11:24 PM   #7
2Stroke
Scooby Specialist
 
Member#: 36712
Join Date: May 2003
Location: RHE, SoCal
Vehicle:
2003 WRX Wagon
WRB

Default

Is your car stock? Any recent mods? Got a UTEC? First time you've had a flashing CEL?

Oh yeah, is your turbo fluid synthetic or did you switch over to intestinal?
2Stroke is offline   Reply With Quote
Old 12-27-2004, 02:41 AM   #8
camz911
Scooby Specialist
 
Member#: 16041
Join Date: Mar 2002
Location: right here..wait..where am I??
Vehicle:
'02 SCRAP METAL
ZERO whp.... :(

Default

Quote:
Originally Posted by railguy
turbo fluid???????
yes, be sure to check the headlight fluid while you are at it....I'm just joking. I'm sure you'll be ok to drive to get it checked. Best of luck.
camz911 is offline   Reply With Quote
Old 12-27-2004, 02:51 AM   #9
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: NWIC
Location: Seattle
Vehicle:
.... OT Supplement
Testing Division.

Default

on a different note, my left turn signal is flashing faster. i think my blinker fluid is low, doenst napa carry it by the gallon?
godfather2112 is online now   Reply With Quote
Old 12-28-2004, 01:16 AM   #10
Beebs99
Scooby Newbie
 
Member#: 73803
Join Date: Nov 2004
Chapter/Region: South East
Location: Gamehenge
Vehicle:
2008 4 Door WRX
OBP

Default

Quote:
Originally Posted by godfather2112
on a different note, my left turn signal is flashing faster. i think my blinker fluid is low, doenst napa carry it by the gallon?
So stupid its funny, or I could just be stoned.
Beebs99 is offline   Reply With Quote
Old 12-28-2004, 01:51 AM   #11
eastcoastbumps
Scooby Guru
 
Member#: 29201
Join Date: Nov 2002
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
BMW M3
Honda S2000x2

Default

CEL's aren't triggered by low fluid levels. It sounds like a misfire problem to me. Have your spark plugs checked (huge PITA, but it could be worth it).

Pete
eastcoastbumps is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What do I need for a fluid change? STi-MAN Service & Maintenance 1 06-06-2005 04:24 PM
GC8 STI HID ... do I need more acronyms? tooocool49723 Electrical & Lighting 4 08-29-2004 10:20 PM
Do we need more Bongo or Cowbell? WHTWRX Off-Topic 1 11-12-2003 06:58 PM
Can I use just a turbo or do I need more? WR-REX Factory 2.0L Turbo Powertrain 5 01-01-2003 03:09 PM
Do I need a turbo timer?? What do YOU do? up4air Newbies & FAQs 16 07-12-2001 08:19 AM


All times are GMT -4. The time now is 10:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.