Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-28-2004, 12:54 AM   #1
MPtyza
Scooby Newbie
 
Member#: 50824
Join Date: Dec 2003
Location: Mertztown, PA
Vehicle:
1988 XT6 FWD 5MT #2
1993 Impreza L

Default No heat

My friend is having a problem with her '93 Impreza. Sometimes there is no heat, and other times it works normally. Could the thermostat be stuck open or something like that when there's no heat? I really gotta find out what's going on and fix it for her cause it's been around 15-20 degrees around here lately. Thanks
* Registered users of the site do not see these ads.
MPtyza is offline   Reply With Quote
Old 12-28-2004, 11:58 AM   #2
North Ursalia
Miss You Mom
Oct 1940 - Feb 2008

Super Moderator
 
Member#: 809
Join Date: Jan 2000
Chapter/Region: NESIC
Location: NH, Land Of Many Trees
Vehicle:
2000 2.5 RS, '14 For
92 5MT SVX

Default

Could be the thermostat, could be the water pump, could be the heater core, could be low coolant, could be head gaskets... lots of things to check .


Brian

North Ursalia is offline   Reply With Quote
Old 12-28-2004, 03:03 PM   #3
MPtyza
Scooby Newbie
 
Member#: 50824
Join Date: Dec 2003
Location: Mertztown, PA
Vehicle:
1988 XT6 FWD 5MT #2
1993 Impreza L

Default

Hmm, I'll be sure to check a few things on it. thanks
MPtyza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So we have no heat... Any temporary heating solutions better than Kero heaters? AcquaCow Off-Topic 104 02-16-2010 06:19 PM
no heat shields six1five Normally Aspirated Powertrain 3 01-16-2004 12:32 AM
Heater - no heat impRSa Electrical & Lighting 5 10-03-2003 01:14 PM
NO HEAT AT WORK: grounds for leaving early? touch New England Impreza Club Forum -- NESIC 29 12-03-2002 11:26 PM
No heat at idle, only when moving, and long warm up period? Need4Boost Factory 2.0L Turbo Powertrain 18 12-01-2002 12:01 PM


All times are GMT -4. The time now is 03:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.