Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-04-2011, 06:00 AM   #701
bane.x07
Scooby Newbie
 
Member#: 275777
Join Date: Mar 2011
Location: El Paso, Tx
Vehicle:
2007 WRX STI
Black

Default

hey i just got my 07 sti today and i wanted to change the cluster to green but keep the tinted faces when off
* Registered users of the site do not see these ads.
bane.x07 is offline   Reply With Quote
Old 03-04-2011, 10:16 PM   #702
mmaxamus2010
Scooby Newbie
 
Member#: 273696
Join Date: Feb 2011
Default

How do you do it using the nailpolish remover? I could find it
mmaxamus2010 is offline   Reply With Quote
Old 03-10-2011, 10:54 PM   #703
Wileycyote
Scooby Newbie
 
Member#: 268173
Join Date: Dec 2010
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2003 WRX Wagon
Silver

Default

Get some nail polish remover and a bunch of qtips. Have some small flat heads around to fix the needles if need be.

Remove the cluster and take off the plastic lens to expose the tach/speed and gas temp gauges. If you look at the back of the cluster you will see holes for the lights and long thin rectangular slots cut out of the back. In those holes you will see a tab a hole with a silver circle then a tab. (I 0 I) Straighten the tabs and push the pannel out by using a small screwdriver to push on the silver circle. There are 2 sets of tabs for each side. They are right behind each gauge.

Once you have each section out you can reach behind the painted layer with a nail polish soaked qtip and remove the green paint. I used about 50 qtips. You can check you progress by shining a light behind the removed pannel.

When you have removed the paint to your liking, carefully press the gauges back in and rebend tabs. Done and looks great.
Wileycyote is offline   Reply With Quote
Old 05-06-2011, 09:21 PM   #704
Scissor
Scooby Newbie
 
Member#: 281484
Join Date: Apr 2011
Chapter/Region: Tri-State
Location: New York
Vehicle:
2005 WRX
CGM

Default

parts express doesn't have the red covers anymore. anywhere else to get them?
Scissor is offline   Reply With Quote
Old 06-08-2011, 07:56 PM   #705
Aprice24
Scooby Newbie
 
Member#: 231892
Join Date: Dec 2009
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2007 Impreza WRX
OBP

Default

Quote:
Originally Posted by Scissor View Post
parts express doesn't have the red covers anymore. anywhere else to get them?
Bump. Anyone else looking to do this?
Aprice24 is offline   Reply With Quote
Old 06-10-2011, 12:33 PM   #706
Twrex2002
Scooby Newbie
 
Member#: 283490
Join Date: May 2011
Default

uh oh, i was planning on trying this.... anyone find where we can get the red covers?
Twrex2002 is offline   Reply With Quote
Old 06-11-2011, 11:36 AM   #707
Aprice24
Scooby Newbie
 
Member#: 231892
Join Date: Dec 2009
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2007 Impreza WRX
OBP

Default

I did this last night and it looks awesome, but now I'm having problems with my speedo working. Any help here?

It looks like my clip popped up into the needle. How can I get it down? Flathead isn't working. Maybe dental floss?

Last edited by Aprice24; 06-11-2011 at 11:47 AM.
Aprice24 is offline   Reply With Quote
Old 06-11-2011, 12:48 PM   #708
Aprice24
Scooby Newbie
 
Member#: 231892
Join Date: Dec 2009
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2007 Impreza WRX
OBP

Default

Update. I was able to fix it. By wiggling the needle slowly back and forth I was able to separate the clip from the needle. From there I could use a small eye glass/computer flathead to push it back down.

It looks awesome, now I'm going to order some stage gels to replace the color.
Aprice24 is offline   Reply With Quote
Old 07-15-2011, 03:33 AM   #709
knbetz
Scooby Newbie
 
Member#: 288123
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Lincoln, NE
Vehicle:
2003 Impreza WRX
WRB

Question new car, christmas tree effect on lights.

So I recently purchased an 03 WRX, half the lights in the gauges were "out" so i thought what the heck i'll just get some LED's and do a overhaul on the lights inside the car. Changed the lights and found out one of the 74 bulbs and twistlocks were completely missing.

Is that why half my gauges (speedometer and tach) are not lighting up? I'm assuming they run in series not parallel, correct?

PS the writeups on changing the color of lights were fantastic help, i'll be doing the radio, hvac, keyring, and boost gauge asap.
knbetz is offline   Reply With Quote
Old 07-26-2011, 05:58 PM   #710
ThatMichiganSubaru
Scooby Newbie
 
Member#: 288162
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
2002 WRX
Silver

Smile



Nice steering wheel! i have the same one =)
ThatMichiganSubaru is offline   Reply With Quote
Old 10-09-2011, 07:47 PM   #711
HFR_WRX
Scooby Newbie
 
Member#: 294789
Join Date: Sep 2011
Vehicle:
2006 WRX TR
Obsidian Black

Default

So question. If I were to throw some #47 red led twist and locks. (Look similar to stock) would they work? Or is it not that simple?
HFR_WRX is offline   Reply With Quote
Old 12-05-2011, 10:46 PM   #712
ShinjiML
Scooby Specialist
 
Member#: 257231
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: Hudson Valley, NY
Vehicle:
2011 STI
DGM

Default

After losing my speedometer light, I decided to do this mod with 3x brightness blue lights from autolumination.com. I'm pretty happy with the results. I didn't scrape off the green filter either. The gauge is actually brighter than it appears in the picture with the red line now purple.

ShinjiML is offline   Reply With Quote
Old 12-05-2011, 10:46 PM   #713
ShinjiML
Scooby Specialist
 
Member#: 257231
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: Hudson Valley, NY
Vehicle:
2011 STI
DGM

Default

double post
ShinjiML is offline   Reply With Quote
Old 02-14-2012, 05:17 PM   #714
ayashifx55
Scooby Newbie
 
Member#: 309809
Join Date: Feb 2012
Location: Montreal
Vehicle:
E46 M3 & Outback

Default

Will 74 LED bulbs work? Thanks.
ayashifx55 is offline   Reply With Quote
Old 02-14-2012, 10:17 PM   #715
rustyg23
Scooby Newbie
 
Member#: 277681
Join Date: Mar 2011
Location: floyd. va
Vehicle:
05 sti
graphite metallic black

Default

Quote:
Originally Posted by ShinjiML View Post
After losing my speedometer light, I decided to do this mod with 3x brightness blue lights from autolumination.com. I'm pretty happy with the results. I didn't scrape off the green filter either. The gauge is actually brighter than it appears in the picture with the red line now purple.

about how long did this take you i would love to do it to my 05
rustyg23 is offline   Reply With Quote
Old 02-15-2012, 11:06 AM   #716
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2012 Legacy
Graphite

Default

anyone ever check these guys out??

http://interiorflair.com/Services.html
Salvation27 is online now   Reply With Quote
Old 02-15-2012, 11:15 AM   #717
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2012 Legacy
Graphite

Default

Also, if anyone is in the NNJ area, let me know, as I'd definitely compensate anyone who can do this............
Salvation27 is online now   Reply With Quote
Old 02-15-2012, 07:14 PM   #718
ShinjiML
Scooby Specialist
 
Member#: 257231
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: Hudson Valley, NY
Vehicle:
2011 STI
DGM

Default

Quote:
Originally Posted by rustyg23 View Post
about how long did this take you i would love to do it to my 05
It took me about 30 min. (including removing the gauge cluster), just be careful to not lose one of the little metal clips on the cluster mount like I did >.>

It's actually really easy, the bulbs just twist off and you twist a new bulb on.

Also, just to note, doing this WITHOUT removing the green film might not work well with all colors. I believe it worked in this case because blue and green are close to each other in the color spectrum.

And yes, the bulb size is 74

Last edited by ShinjiML; 02-15-2012 at 11:37 PM.
ShinjiML is offline   Reply With Quote
Old 02-16-2012, 08:59 AM   #719
rustyg23
Scooby Newbie
 
Member#: 277681
Join Date: Mar 2011
Location: floyd. va
Vehicle:
05 sti
graphite metallic black

Default

Sweet thank you. I am going to do the blue I was looking on that website u linked did u get the led with three lites for wide angle or the signal one they both say 3x brighter.. also anyone have a idea on how to keep the red line still red?
rustyg23 is offline   Reply With Quote
Old 02-16-2012, 11:32 PM   #720
ShinjiML
Scooby Specialist
 
Member#: 257231
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: Hudson Valley, NY
Vehicle:
2011 STI
DGM

Default

I got the "3 LED wide angle 3X brighter" bulbs, it's the third one from the top of the page http://autolumination.com/74.htm
ShinjiML is offline   Reply With Quote
Old 02-20-2012, 07:10 PM   #721
NVsubaru
Scooby Newbie
 
Member#: 247111
Join Date: May 2010
Location: Napa, CA
Vehicle:
2007 Impreza 2.5i
1971 VW Fastback

Default

I've been looking, and I'm tired of doing so, but is there a tutorial on how to change the color of the door switches? I have an 07, and upon opening it up, I realized it was all LED's. Are the LED's green, or is it a film/the plastic on the switches themselves? I just did my cluster/hvac, and I've given up looking around the forum. Any help would be greatly appreciated!
NVsubaru is offline   Reply With Quote
Old 02-20-2012, 07:28 PM   #722
Rubr_Duky
Scooby Specialist
 
Member#: 2159
Join Date: Aug 2000
Chapter/Region: SCIC
Location: Fullerton, CA
Vehicle:
2004 WRX
WRB

Default

Quote:
Originally Posted by NVsubaru View Post
I've been looking, and I'm tired of doing so, but is there a tutorial on how to change the color of the door switches? I have an 07, and upon opening it up, I realized it was all LED's. Are the LED's green, or is it a film/the plastic on the switches themselves? I just did my cluster/hvac, and I've given up looking around the forum. Any help would be greatly appreciated!
I changed the green LED in my door window switch to red. YRMV
http://forums.nasioc.com/forums/showthread.php?t=821215
Rubr_Duky is offline   Reply With Quote
Old 02-20-2012, 08:32 PM   #723
NVsubaru
Scooby Newbie
 
Member#: 247111
Join Date: May 2010
Location: Napa, CA
Vehicle:
2007 Impreza 2.5i
1971 VW Fastback

Default

Yeah, just took it apart again, and there's no film, so LED's it is...time to bust out the 'ol soldering iron...
NVsubaru is offline   Reply With Quote
Old 03-01-2012, 12:32 AM   #724
SSDD22
Scooby Newbie
 
Member#: 294452
Join Date: Sep 2011
Chapter/Region: South East
Location: RockIsland TN
Vehicle:
2007 WRX TR
Satin white peral

Default fuel gauge doesnt work now

So I changed the color of my gauges the other day and noticed my fuel gauge isn't working I've went back and forth taking my gauge cluster apart trying to figure out what is going on with it. I have no clue with what it could be any ideas ?
SSDD22 is offline   Reply With Quote
Old 03-01-2012, 05:09 PM   #725
Rubr_Duky
Scooby Specialist
 
Member#: 2159
Join Date: Aug 2000
Chapter/Region: SCIC
Location: Fullerton, CA
Vehicle:
2004 WRX
WRB

Default

Read the thread again. Many people have had the same problem, and the solutions have been gone over.
Rubr_Duky is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Interior Color Change Tutorial: Radio and HVAC Trunk_Monkey Interior & Exterior Modification 248 10-29-2013 12:47 PM
Interior Color Change Tutorial: Key Ring Trunk_Monkey Electrical & Lighting 70 10-21-2013 06:41 PM
Interior Color Change Tutorial: OEM Boost Gauge Trunk_Monkey Electrical & Lighting 62 05-16-2013 08:02 PM
Interior color change tutorial: Clock WejR20X Electrical & Lighting 9 11-07-2006 03:52 AM
changing Sti gauge cluster color Basshead STi Forum Archive 7 09-12-2003 04:08 PM


All times are GMT -4. The time now is 03:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.