Welcome to the North American Subaru Impreza Owners Club Wednesday August 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-04-2005, 08:14 PM   #1
Scuter83
Scooby Newbie
 
Member#: 59781
Join Date: Apr 2004
Location: Ann Arbor, MI
Vehicle:
2002 wrx sedan
sedona red pearl

Default Autometer Oil Pressure Guage reading weird

Hey, I just installed an autometer oil pressure guage (electric), at idle on the first start up it read near 80psi. I have the wire hooked up for ignition to the radio fuse. Does anyone know why this is reading so weird? I also have the adaptor kit sold from wrxtra.com on it. Thanks for the coming information.
* Registered users of the site do not see these ads.
Scuter83 is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-04-2005, 08:17 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Please don't crosspost.
Mulder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Autometer Electric Oil Pressure Guage meltee Electrical & Lighting 10 09-18-2008 05:35 PM
Autometer Oil Pressure guage reading high? Scuter83 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 01-04-2005 09:55 PM
Autometer Sport Comp Oil Pressure Guage lotusTT Private 'For Sale' Classifieds 2 09-30-2003 06:33 PM
Autometer Oil Pressure Guage Rowdy2.5 Texas Impreza Club Forum -- TXIC 1 06-12-2003 12:22 AM


All times are GMT -4. The time now is 06:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.