Welcome to the North American Subaru Impreza Owners Club Monday May 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-08-2005, 06:29 PM   #1
Ireneusz
Scooby Newbie
 
Member#: 34464
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Roselle IL
Vehicle:
1994 GC8STI /FXTSTI
426whp aspen / 340whp psm

Default Turboxs FMIC Question

Hello

I just installed Turboxs FMIC and after starting up the car hesitates at idle
has anyone had that problem?
I was thinking if UTEC can solve that problem or its somthing that is caused by stock turbo right now.
Has anyone had something like that ohh i have 2004 wrx motor on my 2000 rs

Thanks alot
* Registered users of the site do not see these ads.
Ireneusz is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-09-2005, 09:57 PM   #2
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Check for leaks first off. Is it holding boost like before? Was the installation bolt on, or did you have to bend, cut, modify, shave, etc. anything? Thanks.
garface is offline   Reply With Quote
Old 01-10-2005, 11:50 AM   #3
Ireneusz
Scooby Newbie
 
Member#: 34464
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Roselle IL
Vehicle:
1994 GC8STI /FXTSTI
426whp aspen / 340whp psm

Default Turboxs FMIC

Hey thanks for response

The installation was pretty much bolt on except the front intercooler piping was 2.25 inch to long so i had tu cut and then clamp it with silicone hose besides that everything bolt right on.
Do you think that if total lenght of the piping is 5inch shorter would create hesitation?
I already checked for leaks and seem to be ok.

Thanks for response
Ireneusz is offline   Reply With Quote
Old 01-10-2005, 12:32 PM   #4
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Do you have a BOV now and before you installed the FMIC? Where did you cut it?
garface is offline   Reply With Quote
Old 01-10-2005, 12:36 PM   #5
2superblus
Scooby Specialist
 
Member#: 33526
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Brookfield, Wi
Vehicle:
2013 WRB W/Gold BRZ
08 STI WRB w/Gold, 02 WRX

Default

put washers in the bov, at least 3
2superblus is offline   Reply With Quote
Old 01-10-2005, 03:54 PM   #6
Ireneusz
Scooby Newbie
 
Member#: 34464
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Roselle IL
Vehicle:
1994 GC8STI /FXTSTI
426whp aspen / 340whp psm

Default Turboxs FMIC

Hey

I had to cut the pipes both sides,you know the inlet to intercooler and outlet
both sides 2.25 inch before the 90deg angle to fmic and on the 90deg angle from fmic and conect it with silicone hose from both sides.
Do you think the pipes that i cut made them shorter could cause that.
Thats preety weird if it did.
The wrx's front is little longer thats why i needed to shorten them to fit on to fmic.
As for the bow right now i have 5 washers.Maybe there are to many washers in bow?
I will check tonight and see what happen.


Thanks for help i will try that
Ireneusz is offline   Reply With Quote
Old 01-10-2005, 04:29 PM   #7
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Oh no, I was just askin about the cutting because I'm going to be installing a WRX front mount on my GC soon. The bov or a leak are the only things I can think of. But if you do a search I'm pretty sure a lot of people have issues with front mounts and idling. You have a turbo'd RS engine or WRX swap?
garface is offline   Reply With Quote
Old 01-10-2005, 06:24 PM   #8
wrx plus
Scooby Specialist
 
Member#: 42253
Join Date: Aug 2003
Location: Hampton, Va.
Vehicle:
2003 RWD WRX
Alcohol injected, WRB

Default

Quote:
Originally Posted by 2superblus
put washers in the bov, at least 3
I started with 6 washers and ended with 12 gold dollars in the BOV at 18Lbs of boost. The spring is very weak, keep on putting washers until the whistle at full boost stops.
wrx plus is offline   Reply With Quote
Old 01-11-2005, 02:12 AM   #9
Ireneusz
Scooby Newbie
 
Member#: 34464
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Roselle IL
Vehicle:
1994 GC8STI /FXTSTI
426whp aspen / 340whp psm

Default Turboxs FMIC



Hey problem solved no hesitation car runs smoooooth.
I added 6 washers and the tiny leak stoped also 1 fmic clamp wasn't tight so with higher boost leaked little .
all that made car hesitate.
Now the OBDII problem cell is on it comes up as P1446 and P1491
The scanner shows both as (auxuary emission input fault)

Any idea what that could be.

Thanks
Ireneusz is offline   Reply With Quote
Old 01-26-2005, 01:47 PM   #10
el~sharko
Scooby Specialist
 
Member#: 29735
Join Date: Nov 2002
Chapter/Region: MAIC
Location: Westminster,MD
Vehicle:
2011 JSW TDI - DSG
2008 EVO X MR

Default

Quote:
Originally Posted by Ireneusz


Hey problem solved no hesitation car runs smoooooth.
I added 6 washers and the tiny leak stoped also 1 fmic clamp wasn't tight so with higher boost leaked little .
all that made car hesitate.
Now the OBDII problem cell is on it comes up as P1446 and P1491
The scanner shows both as (auxuary emission input fault)

Any idea what that could be.

Thanks
so you have 11 washers in the bov now, and the idle issues went away? I was having this same problem. I had about 10 quarters in the bov, which didn't completely solve the idle problem, but it wouldn't open on throttle lift causing surge. I still have the idle proble, but I've pretty much ruled out the bov as the problem.
el~sharko is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
quick question on turboxs fmic! chrisc75 Water/Methanol Injection, Nitrous & Intercooler Cooling 8 05-01-2009 12:45 AM
turboxs fmic install on 06/07 question BrooklynSTi Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 1 10-20-2007 03:55 PM
TurboXS FMIC Question (Bumper Beam) Andrew Water/Methanol Injection, Nitrous & Intercooler Cooling 1 03-15-2007 11:19 PM
So i got my TurboXS Fmic kit today...here is some pics w/questions. BoostedAWD Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 12-08-2004 10:33 PM
New TurboXS FMIC question thatdmgud Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 17 09-29-2004 08:04 PM


All times are GMT -4. The time now is 02:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.