Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-07-2005, 12:11 AM   #1
taeyax82
Scooby Specialist
 
Member#: 49465
Join Date: Nov 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
03 Bugeye Wagon
Red

Default swap question

hey.. I just finish my WRX engine swap.. its 03 engine.. with 02 WRX ECU.
I have spec stage 1 clutch.. with fidanza lightened flywheel. GT spec uppipe. and Bosal downpipe with stock cat pipe. and Nivia catback exhaust system.
I was wondering my turbo kinda sound loud.. or is it always like that.. you can hear the turbo spooling up from outside.. and well from inside. well.. I'm kinda worried since i haven't rode any other WRX.. well let me know.. and I have a check engine light on.. I have to check that with a scanner.. as soon as I get it.. well thanks in advanced.. very happy with the swap.. if anyone need help let me know.. I did the swap.. myself.. I'll try to help if i can.. thanks.
* Registered users of the site do not see these ads.
taeyax82 is offline   Reply With Quote
Old 01-07-2005, 01:00 AM   #2
OvenMitts
Scooby Newbie
 
Member#: 46278
Join Date: Oct 2003
Chapter/Region: South East
Location: Knoxville
Vehicle:
96 Impreza
"brighton"

Default

Good job, sounds like a sweet setup.
I would think that unless its a "bad sound", then the turbo noise =
And as long as the engine is running well, a CEL is nothing to worry about, Precision Tune should check your CEL's for free, I believe.
OvenMitts is offline   Reply With Quote
Old 01-07-2005, 04:14 AM   #3
kkanavas
Scooby Newbie
 
Member#: 59532
Join Date: Apr 2004
Chapter/Region: SCIC
Location: so cal
Vehicle:
2004 wrx
silver

Default

it sounds like the downpipe, its normal the cel is probably because of the downpipe also.
kkanavas is offline   Reply With Quote
Old 01-07-2005, 10:07 AM   #4
austenf740
Scooby Specialist
 
Member#: 21519
Join Date: Jul 2002
Location: Austin,TX
Vehicle:
02 WRB WRX
98 RS

Default

the lightened flywheel could also be throwing the CEL couldn't it?
austenf740 is offline   Reply With Quote
Old 01-07-2005, 10:22 AM   #5
Diz
Scooby Specialist
 
Member#: 874
Join Date: Feb 2000
Chapter/Region: RMIC
Location: Colorado Mountains
Vehicle:
2004 Porsche 911
2004 Mazdaspeed MX-5

Default

The best thing to do is hook up a scanner to the OBDII port & pull the code. If you get a code for 'Catalyst Ineffecient' or something like that, it is the DP. A couple vendors here sell the fix for that, which is spliced in between the O2 sensor and the O2 sensor plug.

I don't think a lightened flywheel by itself would cause a CEL. Congrats on getting the swap done.
Diz is offline   Reply With Quote
Old 01-08-2005, 12:40 AM   #6
taeyax82
Scooby Specialist
 
Member#: 49465
Join Date: Nov 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
03 Bugeye Wagon
Red

Default

thank you all .. well it have a CEL before the down pipe was.. installed.. I really don't care.. since it runs perfectly well where is precision.. hmm.. I kinda like the turbo spool up noise.. well hope to get everything done soon.. thanks for looking and and.. I'm going to post up pic.. soon.. I got a zerosport body kit.. with Carbon fiber hood.. with jdm headlight.. let me know how you guys like it.. thanks again for the help.. and concern..
taeyax82 is offline   Reply With Quote
Old 01-08-2005, 09:34 AM   #7
Zephyr
Scooby Specialist
 
Member#: 3362
Join Date: Dec 2000
Location: Central NJ
Vehicle:
2001 I've wired a
Few cars in my day

Default

You are more than likely getting a P0301, P0302, P0303 or P0304 which is a misfire code that is a result of running the lightened flywheel. I've got the same one on my car and for the longest time it would throw those codes. The ECM will eventually learn. Whatever you do do not put on a lightened crank pulley as that will just compound your problems.

Z
Zephyr is offline   Reply With Quote
Old 01-10-2005, 02:21 AM   #8
taeyax82
Scooby Specialist
 
Member#: 49465
Join Date: Nov 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
03 Bugeye Wagon
Red

Default

thank you.. I didn't have time to check the CEL out today.. hopefully this week I'll get it checked out.. but the car runs.. fine.. I found out why the turbo noise were too loud.. someone told me down pipe can make it loud and CAI can make it loud... well very happy with the swap.. I think its worth it.. thanks..
taeyax82 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 WRX swap into 2001 RS swap question dtl1218 Subaru Conversions 14 08-13-2008 01:58 PM
dash swap and motor swap questions aka_tur Subaru Conversions 6 02-27-2007 05:21 PM
EJ20G front clip swap swap questions... 970subaru Subaru Conversions 24 01-01-2005 01:09 AM
Legacy spring swapping question... Kevin H. Legacy Forum 0 11-05-1999 08:07 AM


All times are GMT -4. The time now is 09:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.