Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-09-2005, 06:11 PM   #1
WRX-in-it
Scooby Newbie
 
Member#: 64332
Join Date: Jun 2004
Location: Baltimore MD.
Default Hickups

While under full throttle usual 2nd or 3rd gear at a lower rpm, my car seems to hickup or gasp for power, its jumpy and feels like its not getting enough power? help. It feels almost like the car is studdering and trying to get power but it takes a lil bit what can it be?
* Registered users of the site do not see these ads.
WRX-in-it is offline   Reply With Quote
Old 01-09-2005, 08:25 PM   #2
bboy
Scooby Specialist
 
Member#: 56468
Join Date: Mar 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
04 Improved STI
Dirty White

Default

It could be many things: being that new, my guess would be spark plugs or fuel filter. Other options go the length of my arm. Any CEL code?

Try posting in Service and Maintenance
bboy is offline   Reply With Quote
Old 01-10-2005, 12:05 AM   #3
WRX-in-it
Scooby Newbie
 
Member#: 64332
Join Date: Jun 2004
Location: Baltimore MD.
Default

the only code it read was the 420 code for catalytic ineficiency, due to my turboback exhaust.
WRX-in-it is offline   Reply With Quote
Old 01-10-2005, 05:37 PM   #4
bboy
Scooby Specialist
 
Member#: 56468
Join Date: Mar 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
04 Improved STI
Dirty White

Default

Do you have engine management?
bboy is offline   Reply With Quote
Old 01-11-2005, 09:56 PM   #5
WRX-in-it
Scooby Newbie
 
Member#: 64332
Join Date: Jun 2004
Location: Baltimore MD.
Default

no, dont have U-tec yet
WRX-in-it is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get rid of my Hickups?????? TheSilverFox Off-Topic 49 06-07-2007 09:03 AM
Hickup/backfire on tip-in INERT UTEC 1 05-06-2006 04:45 PM
Auto Hickuping??? SVeer Transmission (AT/MT) & Driveline 1 11-29-2005 04:53 PM
Good Cure for Hickups? Ferg Off-Topic 32 11-18-2002 08:19 PM
I must have hit a bump and my speedom hickuped v6scoobie Interior & Exterior Modification 16 11-29-2000 12:13 AM


All times are GMT -4. The time now is 05:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.