Welcome to the North American Subaru Impreza Owners Club Sunday July 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-10-2005, 05:28 PM   #1
TJRCS
Scooby Specialist
 
Member#: 59199
Join Date: Apr 2004
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2008 STI
DGM

Default Fake Premium Gas???

i topped off my tank with Shell V-Power on Sunday. It's a kinda big one in the block of shady neighborhood. Damn... I did WOT with 2nd, 3rd, and 4th on uphill. I was expecting at least 14 PSI (i'm on AP Stage 1), BUT all I could hit was around 12 PSI!!!! ***??? I feel like i got cheated... I never heard engine ping before, so i'm not sure wheather my engine is detonating or not...

I'm going to reset ECU tomorrow morning to test it out one more time. Hope that it'll be BETTER.
* Registered users of the site do not see these ads.
TJRCS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-10-2005, 09:03 PM   #2
cabe
Scooby Specialist
 
Member#: 55864
Join Date: Feb 2004
Chapter/Region: MAIC
Location: williamsport,PA
Vehicle:
2002 WRX sedan
PSM

Default

That's strange. I'm mostly stock and hit 14 psi. Bad gas maybe? A sheetz by my house accidentally put diesel in the 91 octane tanks and screwed a bunch of people over (only about 2 months ago). One of my dad's friends had just gotten a new outback and the put some sheetz diesel in there (unknowingly of course) and the dealership said it wouldn't hurt anything!! What a crock. I'm sure you didn't get diesel, but maybe some bad gas or something.
cabe is offline   Reply With Quote
Old 01-11-2005, 02:08 AM   #3
casualsurfer
Scooby Specialist
 
Member#: 60773
Join Date: Apr 2004
Location: Indianapolis, IN
Vehicle:
2004 WRX
Silver

Default

Try using Chevron - my dealer put in 87 (!!) gas when they delivered the car to me, it would hesitate like a mofo, I was pissed.
casualsurfer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Premium gas is $1.15!!! Mike Anson Mid West Subaru Owners Club Forum -- MWSOC 154 01-05-2015 08:36 AM
Best Premium Gas (Highest Octane, quality, price...) Zahnster Southern California Impreza Club Forum -- SCIC 3 04-18-2001 08:46 AM
Less then premium gas Scoobie Newbie Canada Region Forum 10 03-12-2001 08:03 AM


All times are GMT -4. The time now is 08:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.