Welcome to the North American Subaru Impreza Owners Club Thursday July 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-11-2005, 08:40 PM   #1
csdotcom
Scooby Newbie
 
Member#: 70654
Join Date: Sep 2004
Location: St. Augustine, FL
Vehicle:
2007 STi
Satin White Pearl

Default Hit a snowbank at 5mph, foglights not working :(

We got a good amount of snow falling here in CT and I was on my way home from a recording session about 2 hours ago, took a left turn and slid right into a snow bank. Wasn't going that fast at all, no dents, a few small scratches on the front bumper...but I noticed my foglights no longer work. Now I just cleared my headlights on sunday...i'm pretty sure that has nothing to do with it. Do you guys think I just knocked some wires loose or something?
* Registered users of the site do not see these ads.
csdotcom is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-11-2005, 08:48 PM   #2
express_wagon
Scooby Specialist
 
Member#: 68346
Join Date: Aug 2004
Chapter/Region: NESIC
Vehicle:
2001 M5
2013 Abarth Cabrio

Default

maybe the impact just broke the bulb itself?
express_wagon is offline   Reply With Quote
Old 01-11-2005, 08:51 PM   #3
the2rz
Scooby Specialist
 
Member#: 46033
Join Date: Oct 2003
Chapter/Region: MAIC
Location: Northern VA
Vehicle:
2008 BMW 335i
Silver/Black

Default

^^^that sounds like it. I don't know if this works for our cars but I had a Volvo that would identify a bulb out anywhere on the exterior of the car by blinking a fast turn signal.
the2rz is offline   Reply With Quote
Old 01-11-2005, 08:54 PM   #4
csdotcom
Scooby Newbie
 
Member#: 70654
Join Date: Sep 2004
Location: St. Augustine, FL
Vehicle:
2007 STi
Satin White Pearl

Default

That could be it, its weird though becuase I only hit the snow bank with the right side of my bumper...and both foglights now do not work. I'll probably just head up to the dealer and see what the deal is, or buy sti foglight covers
csdotcom is offline   Reply With Quote
Old 01-11-2005, 09:04 PM   #5
CalcVictim
Scooby Specialist
 
Member#: 57056
Join Date: Mar 2004
Chapter/Region: NESIC
Location: Brighton, MA
Vehicle:
2006 Miata
Copper Red

Default

just for good measure check the fuse and the bulbs, it's faster then going to the dealer.
CalcVictim is offline   Reply With Quote
Old 01-12-2005, 09:51 AM   #6
sha_zapple
Scooby Specialist
 
Member#: 41012
Join Date: Aug 2003
Chapter/Region: E. Canada
Vehicle:
1998 Legacy L

Default

Go to the dealer Why dont you take a second, an look at the fuses, and how the wires are doing.
sha_zapple is offline   Reply With Quote
Old 01-12-2005, 12:10 PM   #7
MomoWRX
Scooby Specialist
 
Member#: 36823
Join Date: May 2003
Location: West Boca, FL/WPB at Northwood
Vehicle:
03 MBP WRX Sold :(
93.5 Single Supra :)

Default

Quote:
Originally Posted by sha_zapple
Go to the dealer Why dont you take a second, an look at the fuses, and how the wires are doing.

second that, it takes like 5 min to unscrew the fogs and check them out.
MomoWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights not working :( pic inside PureTorque Electrical & Lighting 12 06-20-2010 07:35 PM
Bugeye foglight not working Help! Rodwrx23 Electrical & Lighting 2 07-18-2008 02:20 PM
JDM Foglights not working... suren27 Electrical & Lighting 1 12-06-2007 09:28 AM
Foglights not working mlovro32 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 09-22-2005 08:05 PM
03 foglight not working sonic_boost_wagon Electrical & Lighting 2 08-16-2005 07:00 PM

All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.