Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-18-2005, 01:00 AM   #1
CrazyBabyDoc
Scooby Newbie
 
Member#: 75686
Join Date: Nov 2004
Location: NC
Vehicle:
2002 WRX
black

Default Did Greddy gauges blow a fuse or is it just a ghetto install? Tuner response

So I drive 5hrs to Altered Atmosphere (Gaithersburg, MD) to have my HKS FCON V Pro tuned . . . if you are wondering it's making 297whp@1.0.

Anyway, I had them install Greddy gauges in a dashpod to start (EGT, boost, oil pressure). They wanted to charge up to $444 but I wiggled them down to $276 if they didn't hook up the oil pressure (they still charged me $345, though).

So on my way from MD to DC, I turn on the radio to listen to a CD. It's fine for a minute or so and then it skips. After a few more episodes over a couple of minutes I happen to catch one. It's not a skip . . . the entire radio loses power and then powers back on. In the meantime, the EGT and boost gauges appear to be working although the EGT gauge seems a little flakey.

By the time I make two wrong turns on I-495, I notice the radio has stopped working entirely and the gauges as well.

What do you guys think? Fuse? Crappy install? Yes, these are electrical gauges and no other electrical system appears to be affected.

PS They charged me for 5hrs of labor to install the gauges.
* Registered users of the site do not see these ads.

Last edited by CrazyBabyDoc; 01-19-2005 at 03:57 PM.
CrazyBabyDoc is offline   Reply With Quote
Old 01-18-2005, 01:22 AM   #2
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

Sounds like a crappy install. They most likely tapped the radio harness for power to the gauges and based on your explanation, it looks like they may have shorted or cut through a wire.

I would take the dash apart, pull out the stereo and see what they did.

Calvin
cnk is offline   Reply With Quote
Old 01-19-2005, 03:58 PM   #3
CrazyBabyDoc
Scooby Newbie
 
Member#: 75686
Join Date: Nov 2004
Location: NC
Vehicle:
2002 WRX
black

Default

Altered Atmosphere responds . . .

Terrence,

Good to hear the car is running much better. The gauges looked a little
worn so we are not sure if the EGT gauge is fully up to par. I talked to
the tech and he said he installed the gauges same way we ussually do on the
WRX. We would like to take a look next time you are up this way for you to
make sure everything is 100%. We are wondering if the EGT gauge was bad and
caused a short?

The oil sending unit was put in the gauge box. Let us know if you don't see
it there. I just reviewed your ticket and see we did charge a larger amount
for the install than I had told you. I am really sorry for our confusion
here and I will make sure we refund you the difference (I quoted you $289.00
to install everything less the oil sending unit).

On the gauge location I talked to the tech and he said they were fixed
extremely tight in the pod, and he thought that was where you wanted them.
Next time you are out here we can chance the clocking of the gauges for you.

Thanks,
Mike Mahaffey
2003 350Z 12.8@113mph
1994 Stealth TT 10.7@137mph
MikeM@alteredatmosphere.com
www.alteredatmosphere.com
301.330.8835
CrazyBabyDoc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can anybody learn how to cook? Or is it just something you know? DoinkMobb Off-Topic 102 06-02-2010 05:49 PM
Is it me, or is it just a lil warm outside..... Tainted Love Off-Topic 23 08-26-2006 07:17 PM
So, did Nabisco just go down for the last day or so, or is it just me??? shinsain Off-Topic 14 01-06-2006 04:28 PM
is it stupid in here, or is it just you.. NWS material Fish Off-Topic 47 12-27-2004 04:36 PM
Is the SCCA slow, or is it just me? brandonl Motorsports 3 05-28-2001 12:09 AM


All times are GMT -4. The time now is 07:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.