Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-18-2005, 03:57 AM   #1
elhalisf
Scooby Specialist
 
Member#: 56332
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Clinton Twp, MI
Vehicle:
2005 STI Cobb Stg 2

Default Airbag light problem, on, off, on off....

Well I got a 2004 WRX. I bought it salvage, replaced the airbags, but not the module at first. Had the airbag light on for 6 months. The light started getting on my nerves so I bought a new module for it about 1 month ago. This took care of the light for about 3 weeks. A couple of days ago the airbag light went back on. So I drove with it on for about 30 minutes to my destination, before I turned off the car, it was gone. Parked it for the night. No light when I fired it up in the morning. I stopped by Home Depot for about 20 minutes, and when I started it this time, the airbag light is back on. After about 20-30 minutes driving, it dissappeared again.

So pretty much I have noticed, whenever I turn the car off for less than an 1 hour before I fire it back up again, the airbag light is on. After about 20-30 minutes of driving it dissappears. I tried turning the car on and off to make it dissappear but that didnt work.

Any idea what is going on?
* Registered users of the site do not see these ads.
elhalisf is offline   Reply With Quote
Old 01-18-2005, 07:24 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

Does the light come on when you turn the wheel, and when the light is on does the horn stop working? The clock spring/roll connector assembly in the steering column is probably bad if the airbag deployed and you didn't replace the connector.
There is a procedure in the service manual for reading codes from the airbag module, if you follow that you can get a better idea what is wrong but if you have the symptoms above you need the roll connector.
Mulder is offline   Reply With Quote
Old 01-18-2005, 02:49 PM   #3
elhalisf
Scooby Specialist
 
Member#: 56332
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Clinton Twp, MI
Vehicle:
2005 STI Cobb Stg 2

Default

The roll connector, black ring with yellow type of wire comming out, was replaced. I didnt check if the horn worked while it was on or not but will definitely do that the next time. What I am confused about is why is it working at one point and not at another, just after I shut off the car for 20 minutes and turn it back on.

Turning the wheel doesnt affect the light at all.
elhalisf is offline   Reply With Quote
Old 01-20-2005, 01:05 PM   #4
burton1181
*** Banned ***
 
Member#: 79870
Join Date: Jan 2005
Location: Arizona
Vehicle:
02 WRX
Black

Default

I am expierencing the same thing with my 02 WRX I don't know what to do about it. I didn't notice at first but I re-mounted my turbo timer and I noticed that the air-bag light was on... do you guys have any suggestions?
burton1181 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge / Airbag light problem Bigbadwolf Electrical & Lighting 0 08-21-2009 04:08 AM
Airbag light problems in a dash swapped car psyber_0ptix Electrical & Lighting 0 06-24-2009 12:19 AM
Airbag light problem markadopolus Service & Maintenance 14 07-22-2005 08:05 PM
Airbag light problem. still coloradosti Electrical & Lighting 1 07-05-2004 08:07 PM
airbag light problem?? Blitzwrx Electrical & Lighting 3 01-16-2004 06:26 PM


All times are GMT -4. The time now is 10:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.