Welcome to the North American Subaru Impreza Owners Club Wednesday May 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2005, 10:48 AM   #1
notraceready
Scooby Newbie
 
Member#: 64556
Join Date: Jun 2004
Location: Carbondale, Illinois
Vehicle:
2003 Stg 4 WRX sedan
silver

Default Is this normal/harmful

I've got a vf 30, up, tbe and larger tmic on my 03 wrx. I notice that when I'm accelerating hard and am up there in the rpms that if I suddenly let of the gas that there is a dramatic "shudder" or jolt that's felt in the car. I'm not sure if this is engine jolt or some sort of jolt to the tranny/drivetrain (being a n00b doesn't help me discriminate). This happens when I want to rip through the gears but then become aware of my speed and suddenly let up on the gas peddle. It seems like it's jolting the tranny but I don't know. It doesn't happen if I gradually let off the gas. It definitely sounds/feels bad but is it normal?

Thanks for any feedback
* Registered users of the site do not see these ads.
notraceready is offline   Reply With Quote
Old 01-23-2005, 11:23 AM   #2
sportz135
Scooby Specialist
 
Member#: 43021
Join Date: Sep 2003
Chapter/Region: NESIC
Location: Brookline, MA
Vehicle:
08 Impreza WRX
09 Kawasaki Ninja 250R

Default

that is normal, if your at high rpms and you let off the throttle, it shocks the driveline... im kinda a noob, but im pretty sure thats normal. To counter that shock.. clutch in then let off the gas
sportz135 is offline   Reply With Quote
Old 01-23-2005, 11:33 AM   #3
notraceready
Scooby Newbie
 
Member#: 64556
Join Date: Jun 2004
Location: Carbondale, Illinois
Vehicle:
2003 Stg 4 WRX sedan
silver

Default

OK, thanks sportz. I'll have to be more careful and make sure I clutch-in first in those situations.
notraceready is offline   Reply With Quote
Old 01-23-2005, 02:41 PM   #4
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

Thats weird, I also get the exact same symptoms when I slam on the brakes traveling at high speeds. Makes me come to a dead stop!
fatray is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My clutch is dead at 42K is this normal? Ripper Normally Aspirated Powertrain 9 06-07-2012 07:46 PM
is this normal for the normal headlight sequence for an 07 outback? jawwadh Electrical & Lighting 6 08-08-2008 11:34 PM
Is this normal to do this? SubaruImpreza_power Newbies & FAQs 13 06-23-2004 08:37 AM
Is $2,500 for taxes, plates and doc fee sound crazy or is this normal? twiztid General Community 10 11-07-2002 09:36 PM
Reserve is hard to engage 3 out of 5 times... Is this normal? MrP0nch0 Technical Forum Archive 23 08-29-2000 05:28 PM


All times are GMT -4. The time now is 09:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.