Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2005, 05:51 PM   #1
ProSTI
Scooby Newbie
 
Member#: 77782
Join Date: Dec 2004
Location: Travis AFB
Vehicle:
2005 STI
WR Blue Pearl

Post Need help quick. 05 STI Blitz TT Install

Need some quick help. Did a search and came up with nothing. I just purchased a DATT from Blitz,the one with the boost gauge since I didn't have one, and I think the harness I was sent is wrong. The car will not start. I was looking at the sti ignition harness and the following colors were present: black w/ blue stripe, black w/white stripe, black, w/ yellow stripe, and an all black. Now I know a little bit about electrical wiring and I know an all black wire would indicate a ground wire. I think the blitz harness I was sent has their green wire on the wrong side of the plug and it mates up with the all black wire from the car. Can anyone confirm what STI ignition harness wires mate up to the colors on the blitz harness? Sorry for the long post but hate when I'm sent stuff and it ends up not working.
* Registered users of the site do not see these ads.
ProSTI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help Rebuilting 05 sti 6 speed newstiturbo Transmission (AT/MT) & Driveline 16 02-06-2008 07:53 PM
05 sti apexi tt install moorebl Electrical & Lighting 1 01-26-2006 01:24 PM
Need help quick w/ Autometer boost/egt install 05 WRX Ohannon7 Interior & Exterior Modification 5 07-25-2005 07:50 PM
need help quick, perrin Rear Sway Bar install AndyU Brakes, Steering & Suspension 18 09-21-2004 10:26 PM
need help today: 05 Sti lip: home depot metal bar? DieselClown Interior & Exterior Modification 5 08-31-2004 12:29 AM


All times are GMT -4. The time now is 11:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.