Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-24-2005, 03:21 AM   #1
SlowPoke00
Scooby Newbie
 
Member#: 72361
Join Date: Oct 2004
Location: Northern Cal-izzle
Vehicle:
2002 Impreza WRX
Hey ho Silver, away!!!

Exclamation Radiator Fans wont turn on

So heres the prob... The car runs fine when driving, but when idle, the car starts to overheat. And I think it's because my radiator fans wont turn on anymore. I'm pretty sure that the fuses are blown for the main and sub fan but, I was wondering... I just installed my JDM projectors and tested if they worked, but only tested the lights with the wires for the drive/signal light plugged in, with the active high beam, not connected... could this have caused the fuses for the fans to blow?

After I found out that the fans werent working, ofcourse I connected all the wires for the projectors, so all the lights (driving light, signal, high beam) were working. I just hope its nothing more serious than that

note: yeah, it was stupid to test the lights with the other wires not connected, no need to say it...
* Registered users of the site do not see these ads.
SlowPoke00 is offline   Reply With Quote
Old 01-24-2005, 03:07 PM   #2
SlowPoke00
Scooby Newbie
 
Member#: 72361
Join Date: Oct 2004
Location: Northern Cal-izzle
Vehicle:
2002 Impreza WRX
Hey ho Silver, away!!!

Default

bump ^^
SlowPoke00 is offline   Reply With Quote
Old 01-24-2005, 10:33 PM   #3
don_xtc
Scooby Newbie
 
Member#: 72378
Join Date: Oct 2004
Location: up, UP AND AWAY.....
Vehicle:
3125 Impreza
Trying not to b0rk my car

Default

....hmmm sounds like the thermostat went tits up. I recommend that you get that fix ASAP else this is what could happen..

http://forums.nasioc.com/forums/show...ght=thermostat
don_xtc is offline   Reply With Quote
Old 01-24-2005, 10:44 PM   #4
SlowPoke00
Scooby Newbie
 
Member#: 72361
Join Date: Oct 2004
Location: Northern Cal-izzle
Vehicle:
2002 Impreza WRX
Hey ho Silver, away!!!

Default

but if my thermostat is messed up, why does my temps go back to normal when I'm driving? My temps only seem to rise when I'm idle, and I did notice before, during idle, that the fans would turn on every few mins, now, they just dont turn on at all.
SlowPoke00 is offline   Reply With Quote
Old 01-25-2005, 08:45 AM   #5
don_xtc
Scooby Newbie
 
Member#: 72378
Join Date: Oct 2004
Location: up, UP AND AWAY.....
Vehicle:
3125 Impreza
Trying not to b0rk my car

Default

When you're driving the radiator coolant will be cooled down by air passing through and around the radiator, but when you are sitting idle there is no wind(especially if your fans are not turning on) to cool the radiator or engine for that matter and thus your engine will start to over heat. On another note I believe that the fans only turn on when you're idling, there is no need for the fans to be on when you're driving 100km/hr down the highway. Anyways it's the t-stat that regulates the fans and if the t-stat is bad then it can't tell if the engine is overheating or not and thus it won't turn on the fans.

Last edited by don_xtc; 01-25-2005 at 08:50 AM.
don_xtc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HVAC Fan wont turn on after gauge install HighAspirations Electrical & Lighting 14 07-28-2008 05:52 PM
fan wont turn on? kemosabe Alaskan Impreza Club Forum -- AKIC 10 04-20-2007 01:53 AM
Radiator fans wont kick on chokin Service & Maintenance 8 04-08-2007 12:58 AM
Radiator fans not turning on dan avoN7 Factory 2.0L Turbo Powertrain 6 01-23-2006 12:29 PM
Car overheating & radiator fans not turning on SlowPoke00 Service & Maintenance 10 02-08-2005 02:19 AM


All times are GMT -4. The time now is 07:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.