Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-24-2005, 12:15 PM   #1
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default Fuel pump electrical problem

Alright, I'm having a problem when I turn the key to ON before I start the car, the fuel pump won't prime. Over and over, it's just not getting power. I hear the relay every time and the fuse is fine. I even tried other pumps and other assemblies. I wiggle the harness onto the pump assembly, unplug, just fool with that and then finally it primes. Sometimes it'll run for a minute and shut off again. Sometimes it'll drive completely fine. So what is it? How can I fix this?

Brent
* Registered users of the site do not see these ads.
scoobyimprza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump electrical problem.... UM-WRXer Factory 2.0L Turbo Powertrain 0 04-17-2005 01:28 PM
Fuel pump electrical problem scoobyimprza Subaru Conversions 4 01-24-2005 05:15 PM
Help, fuel pump install problem Mildmanneredman Factory 2.0L Turbo Powertrain 13 09-29-2004 07:26 PM
fuel pump relay problem ?? subaru'd_by_marriage 'Old School' Subaru Forum 4 06-11-2004 12:54 AM
Fuel pump install problem Lo0mis Normally Aspirated with bolt-on Forced Induction Powertrain 11 10-13-2003 04:41 AM


All times are GMT -4. The time now is 10:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.