Welcome to the North American Subaru Impreza Owners Club Tuesday January 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-28-2005, 08:38 PM   #1
JohnGalt00
Scooby Newbie
 
Member#: 17035
Join Date: Mar 2002
Location: Dallas, TX
Vehicle:
02 WRX
Black

Unhappy Help me fix my electrical problem

Thursday night when leaving work, I just noticed an electrical problem with my car: when I turn my headlights on, the light behind the instrument panel doesn't turn on, neither does the radio's backlight. Also, the power door locks don't work, and the dome light doesn't turn on when I open the door in the auto position (middle), but it does work if I flip it to the on position. I've noticed that the light behind the odometer and radio are bright when the headlights are off, and then turn off when I turn the headlights on. Adjusting the dimmer switch on the headlights does nothing. The fuse for the door locks is blown, the fuse immediately blows when replaced. I didn't notice any other blown fuses.

Electrical details of my car:
I have EDM headlights, with a wiring harness I got from a group buy here on nasioc. I have a mechanical boost gauge with the wire for the backlight plugged straight into the illumination fuse behind the change holder. My v1 radar detector is wired into the light above the rear view mirror. I also have a unitech chip with a vishnu wiring harness.

All of those upgrades were done more than a year ago. The last time any maintanence was done on the car was two months ago when the dealer fixed a leaking fuel rail.

Any help diagnosing the problem would be greatly appreciated.
* Registered users of the site do not see these ads.
JohnGalt00 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help me fix my stupid headlight problem... scoobyi Electrical & Lighting 4 12-13-2009 10:22 PM
Help me fix these ej20g problems! JDMFLCL Pre-2002 Factory Turbo Powertrain 12 12-18-2008 12:35 AM
Help me Diagnose this electrical problem vnmvx-0 Electrical & Lighting 1 08-13-2007 03:36 PM
Help me with my electrical problem scoobyimprza Mid Atlantic Impreza Club -- MAIC 11 04-12-2005 02:30 PM
help me fix my cel problem Dr. J Service & Maintenance 0 06-10-2003 11:42 PM


All times are GMT -4. The time now is 09:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.